Stuck (?) with submission missing file

Hello all,

We’ve finished upgrading to OJS 3.1 but it’s currently on a testing environment, still.

I came up with one issue where a submission seems to be stuck. It’s easier to see what I mean on this video:

The submission is missing files (because it was imported from OJS 2.x, where such a thing is possible). Could this be the reason?

How do I process this submission?

In case the video doesn’t load, please go to the URL below:


(remove the extra space after “drive”)

Hi @alexxxmendonca

In your shared video I realized that article has no editor assigned. Could you please assign one and load this panel again to check situation remains the same?
I did a test in my OJS 3.1 local demo and I can submit a article without a manuscript attached but I couldn’t put it in review queue without a assigned editor and/or reviewer (and attaching a file).

Hope it helps.

Israel Cefrin
Public Knowledge Project Team

Hi @israel.cefrin,

I tried to do so but I can’t seem to find the option to do that. Unlike the other submission that there is a bar on the right side of the screen, this submission doesn’t seem to have one.

Hence why I’m stuck.


Hi @alexxxmendonca

When you click in “View metadata” on top bar, does it enable you to edit/change section? If so, please try change or add to a section with some editor assigned to this section then reload panel and double check if box appears back.

Otherwise let me know to try a different approach.

Israel Cefrin
Public Knowledge Project Team

Yes, it does, but the problem persists even if I change the section.

Our journals mostly don’t have editors associated with sections. We instruct them not to because we don’t want submissions going straight to Sections Editors, we want them to sit first on the “Unassigned” queue.

To summarize: what if I don’t have a section with editors assigned to it?

It looks like you’re the author of the submission and are therefore being sent to the author workflow view. If I understand you correctly, this is an unusual condition and you just need a workaround.

If you’re an Editor or Journal Manager or Admin, you can still access the editorial workflow for that submission by modifying the URL. Currenlty the demo is like this:


Change this to:


That should get you to the editorial view, where you can remove yourself as an Author participant. You should then be able to access it normally.

Hi @NateWr,

I did as you suggested and it worked. Thank you.

Is this the expected behavior for when you are both the author and editor of a journal?

This situation may happen often for our journals. Is there a different solution without having to rely on changing the URL? I don’t think that’s going to work.

It is the expected behaviour when you are assigned as an Author to the current stage of the workflow.

I just ran through a couple tests myself and find that when making a submission as an Admin or Journal Manager/Journal Editor, I’m not assigned as an Author and can access the editorial workflow. When making a submission as a Subeditor/Section Editor, I am assigned as an Author and can only access the author workflow. They should still be able to access using the URL trick, if they are assigned as a section editor to the submission.

I think it makes sense to check, before using the author workflow URL, if the user is also assigned in an editor or section editor capacity. If so, we can provide the editorial workflow URL. I’ve filed an issue.

Does the existing setup work for you (if editors, but not section editors, can make submissions and still view the editorial workflow)? If not, I can describe how you can use a hook to change the workflowURL in the meantime.

However, the Author of that submission is not only a Section Editor, but also a Journal Editor and Journal Manager.

Following your logic, shouldn’t I be able to access the editorial workflow?

Hmm, I’m not sure. If the user has a stage assignment as an Author on the submission, they’ll get the author workflow URL. But I’m not sure in what cases that’s assigned. In my own tests, a Journal Editor and Journal Manager did not get that assigned, but perhaps there’s some other criteria, like whether the user has an Author role…


I’m not quite sure if this still fits in OJS 3.1 (I’m using 3.0.2), but it might help.
When the user is a Journal Manager/Editor and Author/Reviewer, and to have access to the correct efitorial workflow, what is done is that because having JM roles, every submission is always presented with full access, so, for the user to access the author ou reviewer workflow, they have to go throught the tasks menu → submission notification.

Best regards