Strings from default.po file not displayed

OJS (upgraded from

Strings apparently dealt with in default.po file are not being loaded when I toggle to locales other than my primary language (es_ES).
If I switch to either English or Portuguese (BR), strings are not loaded. Instead the variables are displayed, as shown in following images.


I’ve found files default.po both in …/locale/en_US/ and in …/lib/pkp/locale/en_US (testing for this language only).
The former includes the missing strings. The later won’t.
I think this is correct. I compared files with those downloaded from PKP for a clean

Tried editing the default.po file at /lib/pkp/locale/en_US but this won’t make any effect, so
I reverted the file to factory settings.

Might it be that for some reason the default.po file is not being loaded from any of the two directories? (don’t know which one OJS uses for this purpose)

Can you suggest any workarounds to solve this?

Thanks in advance for your reply.

Juan Ascanio

Hi @jascanio

These string might be missing on your DB since that they are stored on user_group_settings table. Check it for setting_name = nameLocaleKey and confirm whether you have the expected rows as below:


Hi @israel.cefrin
Thanks for your reply.
I’ll try what you suggest, and let you know about results.

Hi again.
I queried the db as follows, and got results displayed bellow:

MySQL [dbname]> select * from user_group_settings where setting_value like '##default.%' and (locale = 'pt_BR' or locale='en_US');
| user_group_id | locale | setting_name | setting_value                                 | setting_type |
|             2 | en_US  | abbrev       | ##default.groups.abbrev.manager##             | string       |
|             2 | en_US  | name         |               | string       |
|             2 | pt_BR  | abbrev       | ##default.groups.abbrev.manager##             | string       |
|             2 | pt_BR  | name         |               | string       |
|             3 | en_US  | abbrev       | ##default.groups.abbrev.editor##              | string       |
68 rows

Don’t quite know why. Maybe a result of the upgrade to or an unnoticed issue we already had in previous version.

I inserted the translations (pt_BR and en_US) to roles from roles editor in the OJS control panel, where I also saw setting_value displaying the strings as above, both for role names and their abbreviations, and this solved the issue.


1 Like