Still Problem uploading files in copyediting stage [OJS]

Dear Community, dear @asmecher,

After I upgraded to OJS, the problem of not being able to upload files to the “Draft Files” and “Copyedited” sections in the copyediting stage seemed to be solved at first.
(see this post and the corresponding bugfix on github). For most submissions this is also the case, but for a few the problem still occurs. Here is my error log:

[31-Mar-2022 08:17:36 Europe/Berlin] PHP Warning:  Declaration of ManageCopyeditFilesForm::execute($stageSubmissionFiles, $fileStage = NULL) should be compatible with ManageSubmissionFilesForm::execute($stageSubmissionFiles = NULL, $fileStage = NULL, ...$functionArgs) in /home/suburban/public_html/sys/lib/pkp/controllers/grid/files/copyedit/form/ on line 33
[31-Mar-2022 08:17:36 Europe/Berlin] PHP Fatal error:  Uncaught Error: Call to a member function getAssocId() on null in /home/suburban/public_html/sys/lib/pkp/controllers/grid/files/
Stack trace:
#0 /home/suburban/public_html/sys/lib/pkp/classes/controllers/grid/ SubmissionFilesCategoryGridDataProvider->loadCategoryData(Object(Request), 4, Array)
#1 /home/suburban/public_html/sys/lib/pkp/classes/controllers/grid/ CategoryGridHandler->loadCategoryData(Object(Request), 4, Array)
#2 /home/suburban/public_html/sys/lib/pkp/classes/controllers/grid/ CategoryGridHandler->getGridCategoryDataElements(Object(Request), 4)
#3 /home/suburban/public_html/sys/lib/pkp/classes/controllers/grid/ CategoryGridHandler->_renderCategoryInternally(Object(Request), Object(SelectableSubmissionFileListCategoryGridRow))
#4 /home/suburban/public_html/sys/lib/pkp/classes/controllers/grid/ in /home/suburban/public_html/sys/lib/pkp/controllers/grid/files/ on line 131

I am very happy to provide more background information if I am told where to look.

Kind regards

Your error is:

PHP Fatal error:  Uncaught Error: Call to a member function getAssocId()

Did you check the solutions suggested in this post?

As Jason points there, this is usually related with errors in your database integrity (orphaned references).


1 Like

Hi @marc,

thank you for the hint! This seems to be the problem. I’ll try the solution mentioned in the post you have linked above.

Update: Following these SQL-Commands provided by @Elton_Pereira_Leite worked:

Kind regards

1 Like