SOLVED: Problems after upgrading to OJS 3.0.0

I am having several problems after attempting to upgrade from OJS to OJS 3.0.0.

First, I attempted to use the first (non-Git) method of upgrading, but met with this error: My first experience and problems with Local installation of OJS 3.

Secondly, I attempted to use Git to clone OJS to a new subdomain ( but was unable to complete the upgrade due to duplicate table and entry errors (even after restoring the backup taken before anything was started).

Thirdly, I created a new database, imported the backup into it via phpmyadmin, and then attempted the upgrade using this database. It seemed to have worked, and the submissions page was now accessible. However… when I then attempted to view submissions, I could only see those submissions which my user account had submitted (as Editor), and when I attempted to go to the “Users” page I was met with this loading screen: which never loads. The “Active” page is empty.

What can I do?


; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf8 (was set to Off)

; Database storage character set
; Must be set to “Off” if not supported by the database server
database_charset = utf8 (was set to Off)

I have just noticed that my account is not assigned any Editorial roles, but is just set to “Reader”, “Author”, and “Reviewer”. Considering that the Users page is also inaccessible, there would seem to have been an issue with importing the users.

EDIT: After doing some further testing, it would seem that this issue only exists with the Github clone. Creating a test directory, installing without Github, and pointing towards the database I mention in my original post seems to have worked. How can I now get this to work with Github?

Hi @Luke_Scicluna,

The only relevant difference I can think of is this commit. Can you check whether this accounts for the difference between the git version (I presume you’re using ojs-stable-3_0_0 on git) and the .tar.gz version that’s not giving you problems?

Alec Smecher
Public Knowledge Project Team