[Solved] [OJS 3.1.2-1] Clear index/index.php


My friend, I installed OJS3.1.2-1 and I have this url
I would like to switch to this
I’ve seen several topics in the community, but I have not been able to. Would you help me?
I have already changed the .htaccess and config.inc.php and nothing yet! If you can help me, thank you very much.

The first “index” in the URL appears to be a folder name in your document root. This can be eliminated by manually moving the OJS files, say from /home/user/public_html/index/ to /home/user/public_html. This may affect the paths you have specified for the files_dir or public_files_dir in config.inc.php, so be sure to check this.

The second component “index.php” is the restful_urls flag in config.inc.php. For this option to be enabled, you must also add a mod_rewrite override to .htaccess or into your Apache configuration. If your Apache configuration disallows .htaccess files (such as AllowOverride None) you will need to modify the Apache configuration.

After this change you will need to be sure to update any internal links (such as static pages or navigation menu items), external links (which point to your site), and DOIs.

I would approach this one step at a time, moving the files to remove the “index” directory first, then, when everything is confirmed working, enabling restful urls for the application.


It worked! thank you!!!