[SOLVED] OJS 3.1.1 - TinyMCE Image Upload not working

My TinyMCE upload plugin tries to upload forever and ever.
Unfortunately the PHP log doesn’t help much.
On the JS console I get a 500 trying to get this page: http://linguamatica.perl-hackers.net/plugins/generic/tinymce/plugins/justboil.me/ci/index.php but the php is there…
it shows a GET 500 when opening the editor, a POST 500 when uploading the image.

Thanks

Response headers:

HTTP/1.1 500 Internal Server Error
Connection: keep-alive
Content-Type: text/html; charset=UTF-8
Date: Fri, 13 Apr 2018 20:19:10 GMT
Server: nginx/1.13.10
Set-Cookie: OJSSID=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/
Set-Cookie: OJSSID=bgvl4qrqaaugmtlccaaae73jtv; expires=Sun, 13-May-2018 20:19:10 GMT; Max-Age=2592000; path=/; domain=linguamatica.perl-hackers.net
Transfer-Encoding: chunked

This other post helped me. https://github.com/pkp/pkp-lib/issues/1919

  1. Create the site folder under public (probably this is done by the installer, but given I upgraded… If not, making installer create that folder would be nice.
  2. The image is stored correctly, but TinyMCE is adding a domain.com/ojs/public/site/foo where it should be domain.com/public/site/foo.

This second issue is the one giving me trouble atm.
Where can I change the code so that that extra folder is not used? – also, is this just with me, or a general issue?

Regarding the second point: I had the base_url on config.inc.php with the default value (pkp homepage). Put it correct, solved the issue. So, just a matter of guaranteeing that the site folder exists and is writable.

1 Like

Hi,
could you tell me exactly what base_url you put on your system? I have the same problem, but It doesn-t work and I don’t know if maybe my base_url is wrong.

My website is https://erevistas.publicaciones.es and my installation is on /home/ojs. I’ve configured base_url= https://erevistas.publicaciones.es/ojs but it doesn’t work.

Thanks.

Hi

Mine is
base_url = “http://linguamatica.com

the website is exactly that, and I have it installed in /home/linguamatica/root

So, probably you just need to remove the ‘ojs’ portion from the URL.