[SOLVED]Help with importexport page

hi all,
I recently moved our site live from the local install I had.
I tried using the importexport page, but the page broke and just showed nothing.

I tried the same page on my local install, and it worked fine. I don’t know where to start my debugging from.

when I view source on the generated html page, I just get this



the only notable differences between my local install and the live site for now are:

  1. the php version.

local = 5.6.15
live = 5.2.17

  1. the value of files_dir in config.inc.php

please any help would be appreciated.

this might help

thanks for the reply @alirezaaa. I followed the link you provided. this was the output of my error_log:

PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'plugins/importexport/datacite/classes/DOIExportPlugin.inc.php' (include_path='.:/home/journal/public_html/new/journals/classes:/home/journal/public_html/new/journals/pages:/home/journal/public_html/new/journals/lib/pkp:/home/journal/public_html/new/journals/lib/pkp/classes:/home/journal/public_html/new/journals/lib/pkp/pages:/home/journal/public_html/new/journals/lib/pkp/lib/adodb:/home/journal/public_html/new/journals/lib/pkp/lib/phputf8:/home/journal/public_html/new/journals/lib/pkp/lib/pqp/classes:/home/journal/public_html/new/journals/lib/pkp/lib/smarty:.:/usr/lib64/php:/usr/share/pear') in /home/journal/public_html/new/journals/lib/pkp/includes/functions.inc.php on line 32

I couldn’t figure out what was wrong. please I’d need more help

Clearly the paths are not correct.
check the base_url and all other related paths in the OJS config file.

thanks again @alirezaaa for the prompt reply, you are so kind.

I’ve double-checked my path settings and it looks ok.

base_url = http://www.example.com/new/journals
files_dir = /home/journal/jm_all
public_files_dir = public

But my problem still persists. I’m almost losing my mind.

Please suggest for me the next thing to do.

NB: www.example.com is just an example

I noticed same thing also happens when I click “System Plugins”

Is this a clean OJS installation or have you modified any files?
Did you install on Windows and move to Linux?
As it says in the previous link I sent you, change permission for Cache, Public, File folders and subfolders to 777 for testing.
Delete the files in Cache folder and subfolders (it should only contain 4 empty folders).

Yes, I installed on windows and moved to linux… …the only files I modified are template files. I actually created a separate template directory, and copied / modified the files there. no modification on core files like plugins. I’ve also deleted all cache and changed file folders permissions.

Is there any path I need to modify in the database?

PS: I also have an older install on the same sever, which has 755 file permissions on those folders, but I don’t experience that error there. old install has OJS ver 2.4.2. The current one in the new folder has ver 2.4.6.

Did you install a new instance in Linux or imported the previously installed DB from Windows?
If this is a fresh installation, I am out of clues.

I imported everything from a local windows install. including the db

Well, this is a bad idea!
I don`t know if there is anything wrong in your db or whether you can fix it by changing some values. OJS developers should answer you.
I suggest you install a fresh OJS (with your modified files) to a new DB on your linux server and check if the problem persists.
If it was ok, try exporting your content and issues to the new db.

Several classes are re-used across the CrossRef and Datacite plugins via symbolic links. Since symbolic links are treated differently in Windows and Linux, it is easy for them to be broken when transitioning from one system to the other.

A best case fix would be to untar a clean install of the OJS files on your Linux box, then copy over your local modifications again.

Thanks @ctgraham and @alirezaaa for coming to my rescue. I created a new database and moved all my templates, like you advised, and it worked! no more plugin errors.

I really appreciate.