SMTP is not working

  • Application Version - , OJS 3.2.0
  • Description of issue


The smtp seems not work. I sent emails to users via dasboard–>users–>Email. The users received the email always in spam boxes and the sender shown in the email was not the sender set in It was the journal manager.

I tried to turn on show_stacktrace but I found nothing in the php error log. How to fix the issue?

problem solved.

first of all. make sure that the email address in is the same as that of the journal manager.

move “;” before smtp settings. such as

; Enable SMTP authentication
upported mechanisms: ssl, tls
smtp_auth = ssl
smtp_username = no-reply@ssssss
smtp_password = 1111111

rather than

; Enable SMTP authentication
;upported mechanisms: ssl, tls
;smtp_auth = ssl
;smtp_username = no-reply@ssssss
;smtp_password = 1111111

make sure php error log is turned on and make sure show_stacktrace = On. It will help you to find out the problem and help to fix the issue.

1 Like