Single statistics salt file for multiple journals

I am currently using OJS 3.1+ and have multiple instances of OJS running. For most of them I activated the usage statistics plugin and also the user anonymization.

Did I get this right, that the salt in the salt file is changed by OJS daily? If so, could this cause problems when multiple journals try to access the salt file (both for reading and writing)?

Thanks for any advice!



No expertise here? It would greatly be appreciated!

@GrazingScientist the salt property in the config file should be unique for each instance of OJS that you are running. If you are running more than one instance of OJS, every instance needs to have its own salt property and also should have its own files_dir.

I do not believe this config file is ever changed by OJS, but I’m not sure.

@GrazingScientist, yes, the salt is generated anew. As @NateWr said, the file should only be used pro installation and thus cannot cause any problems. (Also, the file is exclusively locked when writing the new salt).

Thank you for the insight! :slight_smile:

So far, this has been the most useful thread concerning the salt file used for anonymising the usage statistics.

Is there an easy way to troubleshoot this process? I have the problem that I followed the steps outlined above (generating the empty salt file and setting the path in the plugin) and indeed the salt file is filled with a salt. No error message pops up.
Still, the opting in/out page does not appear. What does possibly go wrong?

Any help is much appreciated!

Hallo @muellerscheessel,

Did you check the box “Respect data privacy”? Also

Did you check the box “Usage Statistics Privacy Information” in the Website’s Sidebar Settings?

If you do not find the settings, the OJS version, you use, would help. :slight_smile:

Ah! Thank you for the hint! I use OJS and a custom theme that does not include a sidebar and therefore also does not display the “Usage Statistics Privacy Information” you mention. I will hard-link this page in the general privacy statement via [journal-name/usageStats/privacyInformation], and the problem should be solved.
Thanks again!