Shibboleth, implicit_auth = On but login page does not change

We have followed the instructions for using Shibboleth with OJS. We are using OJS We have been unable to get the login page to change. In the file we have set implicit_auth = On - and we have tested that our OJS installation is using the current - but there is no change and the Shibboleth login is not triggered. There are no logs of calls from OJS to our Shibboleth. What are we missing?

Hi, @Ian_Caldwell , the instructions in the admin guide are outdated; this setting needs to be removed from The current method to enable Shibboleth is via the Shibboleth plugin in the Plugin Gallery.

1 Like

Hej @ctgraham Thanks! We have been trying to follow the instructions in the PKP Docs: User Authentication and Single Sign-on

For the Shibboleth plug-in, is this the current version?

Are there instructions or support documents in the Github repository?

I’ve submitted a pull request to update that documentation page.

I see that the Plugin Gallery does not have the latest work on the Shibboleth plugin which enhances the settings form and enables Shib authentication to be optional, rather than required, when enabled.

If you are comfortable with cloning it from GitHub, you can checkout the main branch and install the plugin from there. This work has been code reviewed by the Pitt ULS and is in use by JCU. I know there was extra work put into improving the configuration instructions on the settings form.

I’ll plan to package it for the plugin gallery this week, if you want to wait for the latest features to be available there.

1 Like

@ctgraham fantastic!