Shariff configuration OMP - issue at book page

Describe the issue or problem
Configuration of Shariff plugin does not work at the book page.

Steps I took leading up to the issue
Tried the three possibilities for position on Website Settings / Shariff plugin:

  1. Position = “Publication page” → does not appear at all
  2. Configuration on footer: appears on Home and catalog, but not on book detail page.
  3. Configuration on sidebar: appears on Home and catalog, but not on book detail page. (After setting it up on Website Settings / Setup/ Sidebar)

What application are you using?

Additional information
How can I add Shariff buttons on the book page? I could only find how to include the whole sidebar (but it is weird as I have Make a Submission on the sidebar) on monograph_full.tpl by inserting this code:
{* Sidebars *}
{if empty($isFullWidth)}
{capture assign=“sidebarCode”}{call_hook name=“Templates::Common::Sidebar”}{/capture}
{if $sidebarCode}



Hi @Murilo_Melo ,

I looked at your issue in more detail again on an OMP 3.3.0-13 installation. I am still not able to reproduce it. For all combinations of settings the buttons appear exactly where they are supposed to be.

From the additional information you provided I guess to you are customizing your tempales. Is that correct?

If so, please be aware that the Shariff plugin uses a number of template hooks to add the buttons for different systems, namely:

HookRegistry::register('Templates::Common::Footer::PageFooter', array($this, 'addShariffButtons'));
HookRegistry::register('Templates::Article::Details', array($this, 'addShariffButtons'));
HookRegistry::register('Templates::Catalog::Book::Details', array($this, 'addShariffButtons'));
HookRegistry::register('Templates::Preprint::Details', array($this, 'addShariffButtons'));

You should take care that you don’t remove these hooks from the templates. In the tpl files the hooks look like:

{call_hook name="Templates::Catalog::Book::Details"}

I hope that helps. Otherwise, since I cannot reproduce the problems, unfortunately I am not able to do much more.

Best wishes,