Sending mail via web page doesn't appear in the Gmail Sent Items

Dear all,

We use gmail e-mail address as a journal editor mail. E-mails sent via the OJS3 system web page do not appear in the e-mails sent when we log in to gmail in a browser. E-mails sent from the journal page appear as follows.


Emails sent via regular gmail seem to be as follows.


There are different expressions next to the sender. Do you have this problem or may you help with the solution?

Thanks in advance.

Best Regards

Hi @ikram

If I understand you correctly, in the first case you’re sending emails through OJS, using OJS’ built-in mail functionality, but with a user that has a gmail email address. In that case, the Gmail account of that user will never actually get the email being sent, so it can’t store it in the sent mail folder. You’re not sending the email through Gmail, you’re using OJS.

Also, because you’re not actually sending the email through Gmail, your OJS installation is probably forcing the envelope sender (can you post your email configuration settings?) and that’s why you’re getting the “via” bit instead of the email address.


Your are right. Also as a result of the process done by the authors/reviewers on the web page, the notification e-mails are not visible in the inbox in my gmail account. For example an author submits a new submission. But I don’t receive any mail for this. Our e-mail configuration settings in the config file like this:


Hi @ikram

I’m a bit confused by your screen shot. You have smtp_username and password defined, but your smtp_server configuration option is still commented out, as is the main smtp option. If you want to send mail through Gmail, those need to be uncommented.


Dear jnugent,

This structure is the main structure in the config file of the ojs3 system. What I didn’t add what I add. I don’t understand the problem about smtp_server configuration.

Dear jnugent,

E-mails sent via the OJS3 system web page is a strange way to fall into the Promotions tab :grinning:


What I meant about your posted screenshot of your file was that the lines that enable smtp (smtp = On) still have the semi colon in front of them. That means that they are commented out, and not active. The same for your smtp_server line. If you want to send email through gmail you need to remove the semi-colons in order to turn those features on. Otherwise OJS just sends mail through your server’s own SMTP server and it gets relayed to where it needs to go.


Dear Jason, thank you very much. Problem is solved. Now the mail system is working regularly.

1 Like