Scopus/Crossref Plugin OJS 3.3.011-blank page

Hi All,

I will start to use the plugin but I have faced the following problem.

  1. I installed the plugin via plugin gallery
  2. I went to the plugin settings and fill in the required field.
  3. I saved all
  4. I checked the plugin, yet it doesn’t work

When I check the settings I see a blank page. My changes are not saved. I tried many times however, the Scopus API and CrossRef API are not saved. All are blank.


Hi @Gokmen_ARSLAN,
I have the same problem. Also, after I insert the Scopus API key and the settings are blank, the Google Scholar link on every article page disappeared. Do you have the same problem too?

Hi @transitionacademia

I found out why it is but d not know the answer. The journal theme causes this problem. When I use the default, the plugin works. We need to modify the article details in the theme. do you have thoughts? I will work on it. You may check your problem using this way.

Thanks @Gokmen_ARSLAN
I am already using the default theme but still not working. Have you uploaded a style sheet on advanced settings?

there is no problem when using the default theme. We must modify the following section.
{* PubIds (other than DOI; requires plugins) *}
{foreach from=$pubIdPlugins item=pubIdPlugin}
{if $pubIdPlugin->getPubIdType() == ‘doi’}
{assign var=pubId value=$article->getStoredPubId($pubIdPlugin->getPubIdType())}
{if $pubId}


{assign var=“pubIdUrl” value=$pubIdPlugin->getResolvingURL($currentJournal->getId(), $pubId)|escape}
{if $pubIdPlugin->getResolvingURL($currentJournal->getId(), $pubId)|escape}




			{call_hook name="Templates::Article::Details"}
	<div class="col-lg-9 order-lg-1" id="articleMainWrapper">
		<div class="article-details-main" id="articleMain">

I have not been able to do yet.