Reviewer rating wrong redirect

Describe the issue or problem
After rating a reviewer im getting redirected to this response:
{“status”:true,“content”:“”,“elementId”:“0”,“events”:[{“name”:“dataChanged”,“data”:[353]}]} instead of getting back to the reviewer tab. There are no errors in any log, in the database i can see the rating works and the data is in the database.

Steps I took leading up to the issue

  1. Go to 'review tab of submissions process ’
  2. Click on ‘any assigned user, expand the menu, click reviewer details’
  3. Scroll down to ‘Reviewer rating and select any rating and then confirm’
  4. Response message on browser explained above in describe issue

What application are you using?

Additional information


If more information needed, i can provide. Also i cannot find where the file is located. If anyone knows please share info, i might fix it if i find the location.



Hi @jhrs,

Check the browser’s error console before you click the submit button; I suspect there’s an error of some sort that’s interrupting the normal AJAX handling of the form post.

Alec Smecher
Public Knowledge Project Team

Hello @asmecher,

Thank you for the reply.
There are no errors in the console, opening the form, clicking confirm, no errors, php error log empty, but in the network tab there is only this requests:

Apache logs when clicking confirm button:
“POST /journal PATH/$$$call$$$/grid/users/reviewer/reviewer-grid/review-read HTTP/1.1” 200 0 “https:// journalWeb/workflow/index/Submission ID/3” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36”
*i’ve modified the links and paths

Additional, on my test version, i’ve tested the same function and it works, the test version is running, here is the requests in the network tab after clicking confirm button:

If more information needed, i can provide.

Best regards,

Hi @jhrs,

I’m afraid I can’t replicate this on a 3.3.0-x or 3.4.0-x installation. I still think the likeliest problem is a JS error, but you might be missing it because the page is reloading. There should be an option in the browser tools to persist the console log so you’ll see it even after the reload happens.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

I’ve enabled the preserve log in the console log, here are the screenshots:

I’ve tried in both Edge and Chrome.

Then i tried to compare few js files with WinMerge that i’ve found in the 3.3.0-14 latest release from github with my ojs, found that pkp.min.js is not the same, here is the comparison:

The red line in the middle separates the files, the left one is from the github latest release 3.3.0-14 and the right one is from my ojs.

UPDATE: I’ve WinMerge the latest version from ojs site 3.3.0-14 and my ojs, found few js files that were different, i’ve replaced them and still no luck. Replaced build.js, pkp.min.js, AddParticipantFormHandler.js, SiteHandler.js and CancelActionAjaxFormHandler.js.

And some php files:,,,,,
Still no luck.

Best regards,