Review Report inconsistency between Prod and Dev

Description of issue or problem I’m having:
We have 2 almost identical Staging and Prod servers the only differences are the DNS names in of course. We also make sure all data, files, and software versions are the same. It is actually a copy across from Prod server to Dev server. The issue is that on the Staging server, the Review report has 656055 more records/lines. In term of the file size, the Staging Server Review report file size is 434767KB compare to Prod Server Review report file size is 159555KB.

I am not sure how to find out why this happens. Can someone show me how to figure this out? Very much appreciate any advice and pointer.

Steps I took leading up to the issue:

What I tried to resolve the issue:
I have turned on debug mode in file, and found the queries in main log files that were executed after clicking on the download link but not sure yet what the issue is.

Application Version - e.g., OJS 3.1.2:
OJS version

Review report version:


Additional information, such as screenshots and error log messages if applicable:
I can privately share reports or logs files for investigation if that is needed.



This is a very uncommon and specific user error but I now think it is probably the problem is with my database engine is corrupted. Look at the error I got when doing a database dump command on mysql database:

mysqldump -u root -p mysql > mysql.sql


It might be useful for someone.

I uninstalled mysql, deleted all related mysql data, files, config and reinstall a fresh new mysql, reimported data. Unfortunately the issue is still existing.

Hello all,

Today I found the issue and resolved it. Sharing it here because it may help someone in community. Or perhaps some of the people ran into the same issue without even notice.

To recap, this issue is that Review Reports downloaded from 3 separated OJS instances/servers (even though they have the same database, source code versions and plugins versions). The 3 downloaded Review Reports always have different number of records inside and quite different file sizes.

The problem was with value set for directive “max_execution_time” in the php.ini file. The default limit was 30 seconds, this is fine while your data is still small. Once your data grows bigger, this value will not be sufficient and that will stop Review Reports queries from continuing. Unfortunately this will show no error on front end. Users still get RR downloaded but not completed data. Set this value to higher appropriately will allow the application process to fully finish.

I have found this error burried in the log file as seen below.




1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.