Restfull url now does not work

Hi friends,

I have been using OJS 2.74 for 2 years, and until 14-15 september 2017 my restfull_urls have been working fine. This basically is used to remove index.php from all urls.
Suddenly, on 14-15 september 2017 I realized that it does not work anymore.

Information about my website configuration and server.
→ restfull_ulrs is set ON on file.
→ .htaccess has following code

RewriteEngine On RewriteCond %{HTTP_USER_AGENT} libwww-perl.* RewriteRule .* – [F,L] #RewriteBase /

RewriteCond %{REQUEST_URI} ^(.)//(.)$
RewriteRule . %1/%2 [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$$1 [R,L]

→ My Server information:
Shared Host
Apache Version 2.4.23
PHP Version 5.6.25
Path to Sendmail /usr/sbin/sendmail
Path to Perl /usr/bin/perl

Note: I have four other domains sitting on the same host server. I have similar htaccess to remove index.php=? in urls, and they still work fine. Only issue I have with ojs.
→ My ojs site is addon domain, and it is sitting on outside of public_html folder.

Basically, suppose that my host directory is home/user.
My ojs site is sitting on home/user/
I have another site sitting on home/user/
And My remaining 3 sites are sitting on home/user/public_html

I am not sure that triggers this issue?

When I turn restfull_urls ON, I see that the url path of my journal shown in browser address bar is correct. But all url maps to ojs home page.

Hi @ihlasnobatovich,

The setting should be restful_urls, not restfull_urls. Is that a typo?

Alec Smecher
Public Knowledge Project Team

sorry, yes it is restful_urls. Typo was here, in it is written correctly. Followings are set on my config file.

base_url = “

base_url[index] =
base_url[journal1] =
base_url[journal2] =
base_url[journal3] =

restful_urls = On

disable_path_info = Off

files_dir = /home/user/
public_files_dir = public

force_ssl = On
force_login_ssl = Off

Currently I set my htaccess file as below: (basically as restful_url does not work I force R=301 redirection temporarily, so, is forced to redirect to
RewriteEngine On

RewriteBase /
RewriteCond %{REQUEST_URI} ^(.)//(.)$
RewriteRule . %1/%2 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php/$1 [L,R=301]