Reply-To address on outgoing e-mails is journal primary address, should be individual editor?

Context: I am a Systems Administrator who knows very little about OJS. I’m responsible for maintaining two servers hosting OJS instances. The person who actually set up these journals has left my institution, and the editors of the journals do not work for my institution. I’m in over my head with managing anything within OJS.

Problem: It was brought to my attention by one of the editors of one hosted journal that outgoing e-mails from the system all appear to be coming from the journal address ( (which is fine), but that for some e-mail templates, the reply-to is defaulting to that journal address instead of going back to the editor’s address. Is there a way to change the reply-to setting to default to the editor who triggered the e-mail?

Apparently it was working the way they wanted it, until the recent upgrade from OJS v2.4.8.0 to v3.1.0.1

In particular, this is affecting the Review Request Oneclick template, and multiple Editor Decision templates, but there are probably others.

Additional Info: This OJS instance is configured to use Gmail SMTP.

I did find some related topics already:

That second one in particular intrigued me, as it sounds like there was a deliberate change at some point that would explain what’s happening, except for the fact that this journal was on a newer version than 2.4.6 before the upgrade.

Any help/advice would be really apreciated.

Hi @unbc_sysadmin,

The issue might actually be that you’re using Gmail SMTP; if I recall correctly, it automatically rewrites the sender to the account holder’s address. I’m not sure whether/how it affects the reply-to address. Do you have another SMTP server you could try using?

Alec Smecher
Public Knowledge Project Team

I do have another SMTP server I could try using, but then I’ll probably run into SPF issues. My assumption is that one of my predecessors specifically set up Gmail SMTP to avoid that problem (it is listed as one of the two possible solutions to SPF issues in the FAQ:

Also, we don’t really want e-mail for this journal going through our SMTP server. As stated previously, the journal is not owned/managed by us; as far as I’m aware, we’re only hosting it because one of the editors used to work at our institution, or something like that.

I’ll try changing the SMTP server on a test copy of the server, just to gather some data, but ideally a solution would allow us to keep using Gmail SMTP.

Hi @unbc_sysadmin,

OK – but I’m pretty sure that one side-effect of using Gmail SMTP is that the sender address is forced (beyond OJS’s control) to the account-holder’s name/address.

Alec Smecher
Public Knowledge Project Team

Ok, I did some testing with our dev server.

With SMTP set to our local SMTP server, if I send an e-mail directly to a user, it looks like it’s coming FROM the logged-in account: Sender Name “Sender Personal Address”.

With SMTP set to, if I send an e-mail directly to a user, it looks like it’s coming FROM the logged-in account name, with the journal e-mail address: Sender Name “Journal E-mail Address”

However, if I click Reply To on that second e-mail, the reply is going back to the Sender Personal Address, not the generic Journal E-mail Address. This means when e-mails are sent through gmail SMTP, it supports having a Reply To different from the From address.

To me, this means the issue is specific to the affected e-mail templates. Is there any way to change the Reply To configuration on e-mail templates without having to edit PHP?

Hi @unbc_sysadmin,

The reply-to addressing is hard-coded in the workflow, I’m afraid. However, if you want to take the Recipient address and make it a Reply-to, that should be a single modification (lib/pkp/classes/mail/ in the send function). That’s where OJS maps its emails into the PHPMailer library for sending.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher and @unbc_sysadmin

I’m with same problem here.
Using gmail in OJS2, the reply to field was automatically filled in by the journal’s email.
Now OJS3 just ignore it and send with the gmail account.

That’s a huge problem here, we have 185 journals.
Is there a way to get back to the old behavior? That would solve a gigantic problem in communication.
Today someone needs to look the mail that we use just to send.

I think the best thing to do when it is not possible to change the sender’s email is to put that email as a reply to.

Tarcisio Pereira.

Hi @Tarcisio_Pereira,

Are you using gmail’s SMTP service? I believe that service will always modify the “From” and/or reply-to addresses to the gmail account.

Alec Smecher
Public Knowledge Project Team

1 Like

Hi @asmecher

Yes I’m using gmail’s SMTP service.
At least when we were at OJS2 gmail allows putting any address on the reply-to.

I just tested right now using openssl:

openssl s_client -connect -crlf
Get send an email and gmail accepted the reply to header.
220 ESMTP m10sm3795895qtg.39 - gsmtp
ehlo at your service, []
auth login
334 [hash removed]
[BASE64 login]
334 [hash removed]
[BASE64 password]
235 2.7.0 Accepted
mail from: <[gmail address]>
250 2.1.0 OK m10sm3795895qtg.39 - gsmtp
rcpt to: <[My own mail]>
250 2.1.5 OK m10sm3795895qtg.39 - gsmtp
354 Go ahead m10sm3795895qtg.39 - gsmtp
250 2.0.0 OK 1543429408 m10sm3795895qtg.39 - gsmtp

And I received it working well.

Tarcisio Pereira


I believe there is a bug, in version 2 it worked perfectly and the test indicates that it is possible to put the reply-to.

Tarcisio Pereira

Hi @asmecher

Any light on this issue?

Tarcisio Pereira

Hello all,

I’m wondering if there’s any progress on this or if people who have had this problem have figured out any effective workarounds.

We’re using OJS ( and are also having the issue of the reply-to field being filled with the journal email. This is quite an impediment that adds a lot of friction to our workflow, since it means that for each article, the journal editor has to forward the email to the responsible section editor.

We are also using Gmail for SMTP. However, from what I’m reading from this thread, this looks like an issue with the email templates.

To anyone else who has had this issue: have you effectively changed their templates or modified their OJS installation to alleviate this issue? Would you mind sharing your modifications? (Also, do you need to re-apply your fixes after each update?)

In general, to any OJS developers: it would be really great if this behavior could be changed or exposed through an option. It would go a long way to making editorial workflows smoother.

Thank you!

Hello @asmecher,

We (at UofC) are on OJS ojs-3.1.2-4. We also ran into this same issue where the reply email should be to “a journal editor” instead it went to “the journal administrator email”. And this issue only happens on a certain journals and not all journals, some other email templates in different journals works as expected.

I have tried to modify the roles of “a journal editor” for the problematic journal hoping by changing roles it will correct the issue, but that did not solve. I am willing to modify the email templates (codes) for that journal, but not sure where to find the code. Can you please point me? Or is there any better resolution, suggestion will be much appreciated.

Best regards,


Hello @dung,

Would you mind creating a new forum post about this - and then linking back to this post? We are making an effort to keep the forum more organized and not resurrect older posts.

Best regards,

PKP Team

1 Like