Reinstall only database ==> Some Static Pages produce Error 404

We are still working with oJS
Last month unauthorized person access the webserver and remove the ojs database. Then, the web showed empty page.
We have reinstall the same version of ojs and try to restore the articles through quick submit plugin.
Then, later we recreate the static page. The problem is that when we try to view the static page, it returns 404 error. (this is the link example).
Then we create a new journal (dummy) in the same ojs instalation, And create a static page. When we view the static page of the dummy journal, it works ok (this is the link).

I have check the table journals, static_pages, and static_page_settings to check whether there is inconsistency, but they seem ok.
Is there something that I missed?

I run the query “:select * from versions where product=‘staticPages’;” It return major 1, minor 2.

Here is the content of static_page

This is the static_page_setting

static_page_setting.png842x272 38.8 KB


Problem solved.

I just first deactivate the plugin. Then, reactivate it again. Voila… it works. I don’t know why. I think some configuration was missing from the database.