Registration on LOCKSS with PKP PLN Plugin

Something is wrong there. The version distributed with OJS 2.4.8 should be 1.2.0.0.

What method did you use for the upgrade? Can you refresh the source code using the “Full Package” method, and re-run the upgrade.php script?

Is there any alternative way to upgrade the PKP plugin alone to be 1.2.0.0.? Thanks.

You could download the full package, and just copy the PKP plugin from the package to plugins/generic/pln on its own. Run the update.php script afterwards.

Note, however, that if this one file is out-of-date, others may be as well. I would strongly recommend at least comparing your install to the unmodified download of 2.4.8 so that you can be aware of any and all changes.

Thank you very much. I will try this alternative way.

I did that according to your instructions and the PKP plugin is there now. After I enabled it and agreed with the terms of service, I clicked the status and the page shows that “The PKP PLN is currently in pilot phase and is only accepting deposits from members of the pilot”. Anything wrong? Or I should wait for the OJS to create deposits automatically and move them into the PLN?

This thread seems to indicate that it is now out of pilot:

@mjordan should be able to comment on the Network Status message.

So should we think the PKP PLN is currently still in pilot phase? Because our journal issues are not displayed on that page, in adddition, the Network status shows that.

Yes, we’re out of pilot but require that journals be running OJS 2.4.8. As @ctgraham says, once you upgrade to that version, your journal will start making deposits automatically. The network status message is incorrect; I think we can change it on our end between version releases and if so will update it today. I’ll confirm that when I get into the office.

Thank you. I am pretty sure the version is upgraded to 2.4.8 and the PKP Plugin is 1.2.0.0.

Please look over that.

Hello @Tommy_Tan. Can you share a little more information about your journal? The URL would be useful, as a start.

http://www.smartscitech.com/index.php/ICS

Hi again @Tommy_Tan.

It looks like you’re missing the Archive_Tar library. If you install PHP’s PEAR library, it should include Archive_Tar as well. Here’s a link some instructions for installing PEAR:

http://pear.php.net/manual/en/installation.getting.php

It may take a day for the PLN plugin to contact the staging server, and another full day for the server to acknowledge the journal. Once the journal receives acknowledgement, it will start packaging deposits and sending them to the server. It’s a slow process because it’s designed to have minimal impact on journals.

Hi there. We are very sure the Archive_Tar library was installed. Everything are fine after careful checking.
Now my question is whether the “Network Status: The PKP PLN is currently in pilot phase and is only accepting deposits from members of the pilot.” is wrong or correct? Because mjordan said “The network status message is incorrect; I think we can change it on our end between version releases and if so will update it today. I’ll confirm that when I get into the office.”. So now we are really confused whether the wrong Network Status is from our side or your side since we haven’t got confirmation from mjordan.
Thank you.

Hi mjordan,

Would you update your work on the Network status issue?

Thank you.

We’re investigating, please stay tuned.

@Tommy_Tan of the 69 journals that are currently either ready to deposit to the network or are already making deposits, yours in the first we know of that is receiving the “Network Status: The PKP PLN is currently in pilot phase and is only accepting deposits from members of the pilot” message. Since you are running OJS 2.4.8 you should not be seeing this message. The cause of this is likely a combination of some peculiarity with your journal, most likely not a problem or a bug, just something we haven’t accounted for in how the PLN tools on our end respond to requests to make deposits.

We’ll work it out, and we thank you for your assistance so far. The developer who is most qualified to troubleshoot this is away today, and tomorrow and Monday are holidays here, so I regret to say we won’t be able to investigate further until he returns on Tuesday. We will contact you when we have an update on what we think is going on.

Thank you,

Mark

@mjordan, I see this same message in our 2.4.8+ journals with the PKP PLN plugin enabled.

Surely this must be coming from the server? I don’t see the message anywhere in the local codebase.

Yes, it’s coming from the server, but it shouldn’t be if your journals are running 2.4.8. I need @mjoyce to investigate. Thanks for letting me know you see it too.

Thank you. Expect to have a perfect solution for that.