reCaptcha doesn't support proxy configuration

Hi PKP Team,
As expected I have a problem with proxy settings. This time it is about reCaptcha, I configure it with public and private key but when I try to submit page I get error:
Could not open socket

I have modified /lib/pkp/lib/recaptcha/ to use proxy server but I think that it should be defined to use global '` configuration

38 define("PROXY_HOST", "");
39 define("PROXY_PORT", "8080");
40 define("USE_PROXY", 'true');


83 if( false == ( $fs = @fsockopen(PROXY_HOST, PROXY_PORT, $errno, $errstr, 10) ) ) {

This method isn’t working, I don’t get socket error, but no matter what you type in recaptcha you get error

Errors occurred processing this form:

The characters you entered did not match the characters in the image. Please check the characters and try again.

Hi @knjigor,

I’d suggest investigating the calls to the ReCaptcha library. This is implemented in lib/pkp/classes/form/validation/

Alec Smecher
Public Knowledge Project Team

I have looked at lib/pkp/classes/form/validation/ but couldn’t find any thing that would be related to proxy settings, as I can see file calls lib.pkp.lib.recaptcha.recaptchalib for connection to server.

Hi @knjigor,

If ReCaptcha supported configuring the connection to use a proxy, that’s where it would make the most sense to do it.

However, I haven’t looked at whether ReCaptcha offers that support, and a quick Google turns up at least one indication that it doesn’t. Have you seen this?

Alec Smecher
Public Knowledge Project Team

I have finally found some time to take a look on this.

I have looked at and found that this modification works, but I have modified file lib/pkp/classes/form/validation/ not lib/pkp/classes/form/validation/

I have just pasted provided file because I didn’t have time at the moment to check code line by line, but I will investigate it in next days.

Thanx for help