Quick submit plugin in OJS 3.0

Hi @Cornelle

Could you maybe see in the PHP error log files, if there is an error when you open the QuickSubmit page?

Best,
Bozana

Thanks Bozana. I requested an error log and this is what I get:

[Thu Apr 06 11:48:42 2017] [error] [client 196.255.155.207] PHP Fatal error: Call to undefined method SectionDAO::getSectionTitles() in /var/www/html/plugins/importexport/quickSubmit/QuickSubmitForm.inc.php on line 206, referer: http://
ojsdev.ufs.ac.za/index.php/pie/management/tools

Any advice?

@Cornelle

I think there is a mismatch between OJS- and Plug-In-Version you are using. Are you using the latest OJS 3.0.2 and the corresponding plugin release 3_0_2-0 (s. Releases · pkp/quickSubmit · GitHub)? Did you install the plugin using the plugin gallery? – It looks like you are using the newer OJS version, but the older plugin release 3_0_1-0 – the OJS and plugin version 3.0.1 contain that function (SectionDAO::getSectionTitles()), but it is renamed since then.

Best,
Bozana

Hello, we are using OJS 3.0.1 for two of our journals but right now we are unable to upgrade to 3.0.2. My query concerns if there is by now a stable branch to install the Quick Submit plugin for OJS 3.0.1. We tried to do so by this link GitHub - pkp/quickSubmit at ojs-stable-3_0_1 but we are getting an error message. Does anyone know if there is a stable Quick Submit working for OJS 3.0.1?
Thanks in advance.
Regards
alejandro_shuttera

Hi @alejandro_shuttera,

Is this the same as your other post? Please don’t double-post – it clutters the forum. I’ll respond over there in a sec.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher and @NateWr,

I am thinking to create quicksubmit button in Submission Forms with link to:
http://localhost/ojs/index.php/TestJournal/management/importexport/plugin/QuickSubmitPlugin

The image with button (modify from google chrome dev tools)
imagen

Regards.
xavi.

In order to make this change, you will need to customize the SubmissionsListPanel component in the UI Library (/lib/ui-library/src/components/ListPanel/submissions/SubmissiosnLIstPanel.vue). However, I think you’ll find it difficult to maintain this over time. The ListPanels are still undergoing restructuring as we settle into the new UI component pattern.

It will probably be easier to implement and maintain if you add the Quick Submit button at the top of the page, next to the “Submissions” title at the top. To do that, you only need to overwrite one template file in your theme, and you can keep your customizations separate from the main application.

The template file you need to overwrite is, I think, /templates/dashboard/index.tpl. So if you copy that into your theme, it should overwrite the default.

I tried to override template dashboard in my theme, but it’s not loading.
I copied in my theme/templates/dashboards/index.tpl

I created before tag javascript :

<div id="quickSubmit">
     {help file="submissions.md" section="archives" class="pkp_help_tab"}
      <div class="pkp_content_panel">
              {assign var="uuid" value=""|uniqid|escape}
                   <div id="archived-list-handler-{$uuid}">
                        <button><a name="quickSubmit" href="management/importexport/plugin/QuickSubmitPlugin">{"QuickSubmit"}</a></button>
                   </div>
      </div>
</div>

Do you know If can I override any template (core and lib/pkp)??

Regards,
xavi.
Maybe could be a cache. I tried to clean up.

I’m having a bit of an issue installing and using the quickSubmit plugin on my OJS 3.1.1.0 installation. I installed successfully from the Plugin Gallery, but as soon as I try to run the plugin from Tools → Import/Export → QuickSubmit Plugin, it leads to a blank page.

As suggested in one of the messages on this thread, I looked at the server logs and found these messages:

PHP Notice:  Undefined index: salutation in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 294, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Notice:  Undefined index: first_name in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 294, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Notice:  Undefined index: middle_name in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 295, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Notice:  Undefined index: initials in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 296, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Notice:  Undefined index: last_name in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 297, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Notice:  Undefined index: suffix in /var/www/html/lib/pkp/classes/user/PKPUserDAO.inc.php on line 298, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Warning:  Declaration of LensGalleyPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /var/www/html/plugins/generic/lensGalley/LensGalleyPlugin.inc.php on line 323, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Warning:  Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /var/www/html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 386, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Warning:  Declaration of QuickSubmitPlugin::register($category, $path) should be compatible with Plugin::register($category, $path, $mainContextId = NULL) in /var/www/html/plugins/importexport/quickSubmit/QuickSubmitPlugin.inc.php on line 241, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools
PHP Fatal error:  Uncaught Error: Call to undefined method TemplateManager::registerPlugin() in /var/www/html/plugins/importexport/quickSubmit/QuickSubmitPlugin.inc.php:63\nStack trace:\n#0 /var/www/html/lib/pkp/pages/management/PKPToolsHandler.inc.php(98): QuickSubmitPlugin->display(Array, Object(Request))\n#1 /var/www/html/lib/pkp/classes/core/PKPRouter.inc.php(372): PKPToolsHandler->importexport(Array, Object(Request))\n#2 /var/www/html/lib/pkp/classes/core/PKPPageRouter.inc.php(233): PKPRouter->_authorizeInitializeAndCallRequest(Array, Object(Request), Array, false)\n#3 /var/www/html/lib/pkp/classes/core/Dispatcher.inc.php(134): PKPPageRouter->route(Object(Request))\n#4 /var/www/html/lib/pkp/classes/core/PKPApplication.inc.php(247): Dispatcher->dispatch(Object(Request))\n#5 /var/www/html/index.php(68): PKPApplication->execute()\n#6 {main}\n  thrown in /var/www/html/plugins/importexport/quickSubmit/QuickSubmitPlugin.inc.php on line 63, referer: https://eng-jrnl.canterbury.ac.nz/index.php/bnzsee/management/tools

Any thoughts on what this might mean?

Thanks and Regards

Reagan

SOLVED. Turns out it was an issue related to my botched attempt to upgrade to OJS 3.1.2.0 a while back. Just completed the upgrade and the plugin seems to be working just fine now.

Hi reagan,
Can you please elaborate more on how did you botched upgrade you previous attempt and how did you fix it? In that way you can help me and other fellows regarding this error. Thank you very much

I wasn’t aware then that the upgraded version of OJS would be installed into a new directory, and was expecting the original OJS directory to contain the upgraded installation. So obviously, when I was loading the OJS site using the directory containing the older OJS version, a number of things including the QuickSubmit plugin weren’t quite working as expected.

Oh, that was a technical error. Thank you very much for your answer.

For those who are still struggling, perhaps it was all about different version on your ojs and your plugin. You can check you journal setting to see your version and go to Releases · pkp/quickSubmit · GitHub to download the appropriate plugin version.

Hi all,

Better still, use the plugin gallery within OJS to find and install plugins. It will ensure you install the correct version.

Regards,
Alec Smecher
Public Knowledge Project Team

Oh, i didn’t know we can do that.
Thanks a lot Alec.

Makasi, thanks To putu Mega, thanks for link that you recomend, Its work. Thanks so much

When trying to install the quick submit plugin from the list of modules in the plugin gallery and choose the option to install and select the ok button, it remains without doing any action and does not install the plugin (seeQS the photos), what should I do? Thank youQS1

Hi @Yra_Rojas,

See this post: OJS 3.1.2 Plugin Gallery Error - Cannot Install ANY Plugin - #15 by asmecher

Regards,
Alec Smecher
Public Knowledge Project Team

Hello,@asmecher thanks for replying, should I be the administrator of the installation of the OJS to make these changes? i´m support editorial

Hi @Yra_Rojas,

This requires access to the OJS configuration file and knowledge of the server environment, so yes, it’ll probably require help from your system administrator.

Regards,
Alec Smecher
Public Knowledge Project Team