Problems with Search on OJS

It’s very simple: the search function on our OJS journal website (Application Version: OJS does not work. Every search returns “no results found”

We have tried to contact our (limited) tech support repeatedly over two months but can’t get any help.

I can’t find any way of altering the way the search works on the Dashboard - all you can do is change the name or remove it. And I have tried removing and re-adding it, and that makes no difference.

We really need this function to work as students all over the world rely on to be able to find the right articles.



Hi @DavidMW,

This isn’t exactly the same problem, but in this post here, it is suggested to rebuild your search index to see if that makes a difference: Search Isn't Working - PHP Warning - #2 by jnugent

Could you give that a try? If that doesn’t work, then it might be best to check your error logs and report here on any relevant errors that might be happening.

Best regards,

PKP Team

Thanks, for all of this, I would need our technical people to talk to me, which they aren’t right now…

Here’s hoping.


Okay, with that procedure in the thread you linked to, everything has been resolved for all journals on the Queen’s OJS site - I am surprised no other journal seemed to notice anything was wrong before. I guess our journals gets more use by students etc.