Problems installing / Database Error

Hi, I’m a designer with little and limited knowledge on coding (html and css).
I tried to install a ojs on my website (as a test before I do the installation at a friend’s site) and when doing that I faced this problem :"“A database error has occurred: No such file or directory”.

I also tried to do a local install using Mamp, and everytime I do it says: “The localhost page isn’t working”

Somehow I think they are the same problem. I am trying to install the version ojs-2.4.8-1
Does anyone knows what is happening?


Hi @Karla,

The first error suggests that you’re having a MySQL problem – check to ensure that MySQL is running and configured properly. See e.g. this StackOverflow thread.

On the Mamp server, check your PHP error log; there should be something more concrete there.

Alec Smecher
Public Knowledge Project Team

thanks Alec! I got it resolved.
After looking at your message, i took a close look at the host of the site and realized that I needed to create a database prior of installing the ojs.