Problem upgrading OJS from to

I have tried to upgrade from OJS to via the patch. I downloaded the patch, unzipped it and ran the patch command without problems. Then, I changed the installed-option in my file to off and started OJS. There, I went to “OJS upgrade” and clicked “Upgrade Open Journal Systems”. This ran a little and then produced “Error parsing scheduled tasks XML file: plugins/importexport/medra/scheduledTasks.xml”.

When I change the installed-option in back to “On”, I can log in and everythings seems to be there. But, I still am warned that I run version

Any suggestions what I need to do or where I need to check?


Check the file plugins/importexport/medra/scheduledTasks.xml for malformed XML, perhaps a patch conflict with characters like:


It is usually best to upgrade using the “Full Package” install rather than a patch based install. If you’re not deliberately managing local modifications to the code, replacing the source with a clean copy is the best option.

Once the error is resolved, re-run the upgrade script.

Many thanks! I checked the xml file and it looked OK (also compared to others). Then, it occurred to me that it may be an access problem and that I did have problems earlier with SELinux. I ran the appropriate “restorecon” command and that solved the problem.