Problem upgrading from to

Hello everyone,

Description of issue or problem I’m having:

I am having problem upgrading from to

PHP Fatal error: require_once(): Failed opening required '/lib/pkp/plugins/metadata/mods34/' (include_path='.:/usr/share/php') in /lib/pkp/includes/ on line 25

/ on line 25:

if (!function_exists('import')) {
        function import($class) {
                $filePath = str_replace('.', '/', $class) . '.inc.php';
                require_once(BASE_SYS_DIR.'/'.$filePath); # <-Line 25

The file “/lib/pkp/plugins/metadata/mods34/” does not exists, it is also not in the Gitlab repo in the /lib/pkp/ folder.
So I am a little confused.

Steps I took leading up to the issue:

Tried to upgrade to V3.3.0.10

Steps I took leading up to the issue:

1. Replace code base from to
2. Migrate /public, /, /files, /plugins
2. Run php upgrade.php check 
3. Run php upgrade.php upgrade

Additional information, such as screenshots and error log messages if applicable:

I run an Ubuntu 20.04 LTS with PHP 7.4.3 and mysql Ver 8.0.29.

I searched the Forum to find some similar Problem but without any luck.
Maybe someone has had the same problem and in best case a solution?
Thx in advance!

I’ve found the file in the “old” Version and after moving it to the upgrade folder the error is gone but luckily an other one took its place… Well off to the next I guess :see_no_evil:

Hi @Karl,

How did you get the source code? If you’re using git, you should fetch the PKP library which is a different repo. Maybe you’re missing that?

If you use the .tar.gz download file from the PKP downlad page, you will get the full source code.

Here’s some useful docs:

1 Like

Hi @gonzalognzl;

Thx for the tip!
I’ve tried to upgrade via full source, but probably git is the easier method.
I’ll give it a try. I am pretty sure it was some stupid error on my side :wink: