Problem of ordering of articles in TOC


We are running OJS 2.4.7-1 after relatively troublesome upgrade from OJS2.3.7. However, most of the problems were fixed.
Now we encounter the problem of ordering articles in the TOC which worked fine in OJS2.3.7 version. Namely, when we want to reorder articles by using those up/down pointing arrows, the system without announcing any error takes us to the User Home page. Sections reordering by using the same method works fine.
It looks like the error is connected with the following error we found in the error-log file on the server:

[15-Apr-2016 17:20:02 Europe/Berlin] ojs2 has produced an error
** Message: WARNING: Missing argument 1 for Article::getPubId(), called in /home/iapchemo/public_html/pub/ojs/cache/t_compile/%%72^72A^72A158C2%%issueToc.tpl.php on line 133 and defined**
** In file: /home/iapchemo/public_html/pub/ojs/classes/article/**
** At line: 264**
** Stacktrace: **
** Server info:**
** OS: Linux**
** PHP Version: 5.3.29**
** Apache Version: N/A**
** DB Driver: mysql**
** DB server version: 5.5.48-cll**

There were many similar errors in the error-log file.
Any suggestion?
Many thanks in advance.
Best regards,

Hi @zmandic,

Can you try flushing your template cache? It looks like some old code is in there. Try…

rm cache/t_compile/*.php

Alec Smecher
Public Knowledge Project Team

Thank you Alec for your response.
I deleted all .php files from the t_compile folder but the problem persists ?!


Hi @zmandic,

It looks to me like your templates/editor/issues/issueToc.tpl still contains code from an older version of OJS. Please double-check that it’s the same as the OJS 2.4.7-1 version. If it isn’t, review your upgrade to make sure you haven’t accidentally mixed code from the two versions together; the same problem is likely to crop up elsewhere.

Alec Smecher
Public Knowledge Project Team

Problem solved by replacing the old tpl file with the new one!
Thank you Alec very much for your prompt and useful response.