PN Plugin not being triggered

We are running OJS and have installed the PKP PN Plugin [version] through the plugin gallery. As far as I can tell the plugin is not being triggered. I click the reset button for an issue in the Plugins Status page I get the warning message and click confirm, and nothing seems to happen.
Also the entry plugins.generic.pln.classes.tasks.Depositor in the scheduled tasks has not changed since August of last year and the PKPPNDepositorTask schedule task log files verify that as well, no new files since August. The user stats plugins are working as those db entries are being updated so scheduled tasks are working.

The php error log doesn’t reveal any clues either. Do you have any suggestions of where I can look to determine the problem?


Hi @jhennig,

Can you have a look at some of the troubleshooting tips offered here: GitHub - pkp/pln (towards the bottom of the README). If none of those have worked out for you, let me know and we can see about exploring other options.

PKP Team

I ran the Acron plugin and it seemed to have kicked things into gear.
The plugins.generic.pln.classes.tasks.Depositor last_run date is now updated and it seems the status’ of the issues are being updated. Although some of them are showing a package failure but that is a separate issue at the moment.

My understanding was the cron job for the scheduled tasks should have initiated the plugins.generic.pln.classes.tasks.Depositor just like the stats collection am I wrong on that or is something configured incorrectly?


So I think that the depositor task stopped executing when we upgraded to as the dates in the logs match with the upgrade date.
The running of the acron plugin somehow kicked it back in and it has run automatically the last 2 days.