Plugin to render XLM with only images

I have problems with the plugin used to render XML in the OJS. XMLs that do not have tables, only graphics, the graphics are not displayed; the only solution so far is to put a table tag in the body of the XML so that the images are displayed, but I would like to fix the plugin so I do not have to modify my XML.

Installing the latest version of the GitHub - asmecher/lensGalley: Galley viewer plugin integrating eLife Lens for OJS 3.0 plugin crashes.
I tried using other plugins, but none worked.

Articles that have tables appear smooth.
My OJS version is

Any solution without having to modify XML?

Hi @juanivan92,

You mention that the plugin crashes? Do you see any errors in your PHP erorr log, and if so, what are they? How did you install the plugin (the plugin gallery?)

PKP Team

The webpage down when I install the latest plugin from GitHub.
I installed the plugin in the generic plugins folder.
In the php log it gives me this error

thrown in /home/medicina/public_html/plugins/generic/lensGalley/ on line 26
[12-Mar-2023 22:07:08 UTC] PHP Fatal error: Uncaught Error: Class ‘PKP\plugins\GenericPlugin’ not found in /home/medicina/public_html/plugins/generic/lensGalley/
Stack trace:
#0 /home/medicina/public_html/plugins/generic/lensGalley/index.php(18): require_once()
#1 /home/medicina/public_html/lib/pkp/classes/plugins/ include(‘/home/medicina/…’)
#2 /home/medicina/public_html/lib/pkp/classes/plugins/ PluginRegistry::_instantiatePlugin(‘generic’, ‘plugins/generic’, ‘lensGalley’, ‘LensGalleyPlugi…’)
#3 /home/medicina/public_html/lib/pkp/classes/core/ PluginRegistry::loadCategory(‘generic’, true)
#4 /home/medicina/public_html/lib/pkp/classes/core/ Dispatcher->dispatch(Object(Request))
#5 /home/medicina/public_html/index.php(69): PKPApplication->execute()
#6 {main}

Hi @juanivan92,

Thanks for the additional information. Installing directly from github, while feasible, is not preferable. Installing through the plugin gallery is better because it completes a number of compatibility checks before installing - so you may want to try uninstalling and reinstalling from the plugin gallery as a first step.

PKP Team

When I try to install/update from gallery I always get this error message
The “exec” PHP function has been disabled on your server. Contact your system administrator to enable it.
I had this error before, so I used the method of uploading the plugin to its folder.

If your system administrator will not enable the PHP exec() function, it is possible to directly upload the files to the server. You must take extra care to ensure the version your are uploading is compatible with your version of the software, however.

In this case, downloading from the main branch of GitHub - asmecher/lensGalley: Galley viewer plugin integrating eLife Lens for OJS 3.0 is the version for OJS 3.4. The version for OJS 3.3 is found in the stable-3_3_0 branch. Note that downloading directly from GitHub may also require loading external dependencies (like composer or npm) manually for other plugins.

1 Like