PKP PN Plugin is not working OJS

Description of issue or problem I’m having:
PKP PN Plugin was installed by Plugin Gallery.
PHP Version 7.4.25
Sin título

The status is:
Network Status: The PKP PLN does not know about this journal yet.
ScheduledTasks Log:
[2022-01-04 09:53:57] [Notificación] Depositor processing for Revista Ingeniería UC. [2022-01-04 09:53:57] [Aviso] Your system must have a tar executable.

Hi @Ingenieria_UC,

that message typically indicates that not enough time has passed in order for the PKP PN to have captured your journal, or possibly that you do not have cron configured correctly, please see here: PKP Preservation Network

Best regards,

PKP Team

Do you have the Archive_Tar PEAR extension installed?

Yes, We have Archive_Tar PEAR extension installed.

Hi @Ingenieria_UC,

Check the tar setting in the cli section of your file. Is this setting configured, and does it point to an executable that PHP can access?

Alec Smecher
Public Knowledge Project Team

Our cli:
tar = /usr/bin/tar

Now, we have obtained this error message:
Network error Client error: POST resulted in a 400 Bad Request response: <?xml version="1.0" encoding="utf-8"?> <sword:error xmlns=“Atom Syndication Format namespace” xmlns:sword="http://purl. (truncated…) connecting to the PKP PN to send the deposit.
Sin título

Hi @Ingenieria_UC,

Did you change your configuration to resolve the Your system must have a tar executable error message? Or are you still receiving that error message?

Alec Smecher
Public Knowledge Project Team

We had updated, since two days ago; yesterday we got this error in the status section of PKP PN plugin.

Hi @Ingenieria_UC,

It may take a while for the PKP|PN service to get around to your journal; I’d suggest watching for changes for the next week or two.

Alec Smecher
Public Knowledge Project Team


This is the Editor-in-Chief of The Iraqi Journal of Veterinary Medicine.

We run OJS version ‎, which was updated on December 1, 2021. We do have the same technical problem related to the PKP PN plugin status as it continues (> 24 h, actually > 1 month) to display “Network Status: The PKP PLN does not know about this journal yet.”
Status Description
* Pending: The process of the deposit has not yet started.
* In Progress: The deposit process is in progress.
* Completed**: The deposit process is completed.
* Error: There has been an error regarding the deposit process.
It might take several days for a deposit to be fully processed.

As a veterinarian, I have no clue about this issue, especially if the journal is looking for a new website administrator to resolve it. Additionally, our membership acceptance in the Open Access Scholarly Publishing Association (OASPA) now depends on resolving this issue.
Could you please help us to fix this problem? Well, if the help could be without the technical terms that I have to check, it would be great.

By the way, we would like to make our website look more official. Could you please direct us to the best service we can get with the overall fees? It would be really appreciated.

Your efforts are really appreciated,

Thank you,

Falah AL-Rekabi
The Iraqi Journal of Veterinary Medicine


There are some troubleshooting instructions in the README document for the PKP|PN plugin; see:

In particular check out the lines about the log files; these will probably indicate where the system is running into trouble depositing content.

Alec Smecher
Public Knowledge Project Team

We also have problems with the export for OJS
The task is scheduled and runs.
In the scheduled tasks log file (PKPPNAblieferungsaufgabe-61e806ccee059-20220119.log) it says:

2022-01-19 12:40:44] https://www.???.de
[2022-01-19 12:40:44] [Anmerkung] Geplante Aufgabe wurde gestartet.
[2022-01-19 12:40:44] [Anmerkung] PLN Depositor executeActions started
[2022-01-19 12:40:44] [Anmerkung] Ablieferung wird durchgeführt für ??? Online-Journal | ??? - The Online Journal.
[2022-01-19 12:40:44] [Warnung] Ihr System muss über ein tar-Programm verfügen.
[2022-01-19 12:40:44] [Anmerkung] Geplante Aufgabe wurde beendet.

It asks for a tar program. However, it is only a warning, and no error message for this showed up in the UI (such as for a missing ZIP Archive).
Also, the task stopped as it should.

So far, we only have phar tar installed. Do we need to have pear archive_tar installed also?

Many thanks!


We installed the pear archive_tar, and now get the same network error message as @Ingenieria_UC:

<?xml version="1.0" encoding="utf-8"?>
<sword:error xmlns=""
       xmlns:sword="http://purl. (truncated...)
 beim Versuch, die Ablieferung an das PKP PN zu senden.
[2022-01-20 12:41:21] [Anmerkung] ##plugins.generic.pln.depositor.transferringdeposits.processing##
[2022-01-20 12:41:21] [Anmerkung] ##plugins.generic.pln.depositor.transferringdeposits.processing.postAtom##
[2022-01-20 12:41:21] [Anmerkung] ##plugins.generic.pln.depositor.transferringdeposits.processing.resultFailed##
[2022-01-20 12:41:21] [Anmerkung] Netzwerk-Fehler Client error: `POST` resulted in a `400 Bad Request` response:
<?xml version="1.0" encoding="utf-8"?>
<sword:error xmlns=""
       xmlns:sword="http://purl. (truncated...)
 beim Versuch, die Ablieferung an das PKP PN zu senden.
[2022-01-20 12:41:21] [Anmerkung] Geplante Aufgabe wurde beendet.

And in the error.log:

[Thu Jan 20 13:41:21.471321 2022] [php7:notice] […] PHP Notice:  Undefined index: status in /var/www/html/plugins/generic/pln/classes/ on line 476
[Thu Jan 20 13:41:21.471331 2022] [php7:notice] […] PHP Notice:  Undefined index: status in /var/www/html/plugins/generic/pln/classes/ on line 490
[Thu Jan 20 13:41:21.471345 2022] [php7:notice] […] PHP Notice:  Undefined index: result in /var/www/html/plugins/generic/pln/classes/ on line 494

Hi @felixhelix,

In the file, make sure you specified the location to a tar binary in cli section:
Alec Smecher
Public Knowledge Project Team

Dear @asmecher , dear @felixhelix
as far as I can see, the tar executable is not used anymore by the latest version of the PLN Plugin, isn’t it?!
See my recent findings on paths for the PLN Plugin: PKP PLN Plugin ask for Archive_Tar PHP extension - #49 by klausru
Make sure PEAR is in open_basedir AND include_path (with first in order)
All the best

Thanks @asmecher and @klausru,
IT says that the path in the config is O.K.

Also, I cannot see how the error message is related to the tar executable:
After the installation of pear archive_tar

  • we get a different error message than before ( 400 Bad Request)
  • and no longer a warning of a missing tar program in the error log
    So the installation of the pear archive_tar seems to have been successful?

In the README there is no mentioning of tar as a requirement, only ZipArchive and CURL. But in the code it is mentioned that BagIt needs a tar executable. So something is at odds here.

Any other ideas what to check?

Thanks a lot!


@asmecher @klausru
I “resetted” each individual issue by clicking the “reset” link in the list of deposits, and now for each it shows the status “pending”!
So maybe it had to do with the task as it was called by the scheduler, or by the fact that there have been 10 issues to be deposited at once.
I keep you updated …

I am joining the company. The PKP PN plugin does not appear to work after upgrading to OJS (actually, after upgrading from OJS 2 to OJS 3, but this version is out first with the support for the plugin).
I tried to wrap my head around this problem for a while, but I am still not sure what is causing the problem.
screenshot 2022-01-22 201911
For the most time tle logs say this:

[2022-01-01 21:56:36]
[2022-01-01 21:56:36] [Notice] Task process started.
[2022-01-01 21:56:36] [Notice] PLN Depositor executeActions started
[2022-01-01 21:56:37] [Notice] Depositor processing for Philosophical Problems in Science (Zagadnienia Filozoficzne w Nauce).
[2022-01-01 21:56:37] [Notice] Getting service document.
[2022-01-01 21:56:38] [Notice] Processing deposit status updates.
[2022-01-01 21:56:38] [Notice] Processing updated content.
[2022-01-01 21:56:38] [Notice] Processing new content.
[2022-01-01 21:56:38] [Notice] Packaging content for deposit.
[2022-01-01 21:56:38] [Notice] Trying package deposit 29 (Issue: 30) (Local Status: [New], Processing Status: [Unknown], Lockss Status: [Unknown])

The tar seems to be correctly installed (and works in most other cases):
Zrzut ekranu 2022-01-22 203153


On an additional note, the deposit reset button has no effect whatsoever (seems to not working and does not give any feedback after clicking). The php log says: - [22/Jan/2022:20:34:25 +0100] "POST /index.php/zfn/$$$call$$$/plugins/generic/pln/controllers/grid/p-l-n-status-grid/reset-deposit?depositId=29 HTTP/1.1" 500 - "" 

As of today, 24.01.2022, the PKP ON Plugin on our site reports “In Progress” for all issues. And the network status changed to “Network Status: The PKP PLN can accept deposits from this journal.”