PKP pn plugin installation problem

Description of issue or problem I’m having:
I want to install plugin pkp pn for archiving but it is giving problems… I have installed it though cpanel by uploading it manually to generic plugins folder but it is not creating the desired db tables.
I have tried and disabled exec() and installing it from Plugin Gallery but it always gives error:
The uploaded plugin archive does not contain a folder that corresponds to the plugin name.

[17-Mar-2022 04:34:05 UTC] PHP Warning: exec() has been disabled for security reasons in /----/pkp/classes/plugins/ on line 62

Steps I took leading up to the issue:
I have disabled exec from disabled_functions from whm.

What I tried to resolve the issue:

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:

Hi @sohailkmu,

Have you tried installing it through the plugin gallery as well? That is the preferred method for installing plugins.

PKP Team

Hi @sohailkmu,

Currently there is no way for the plugin to automatically install itself without using the PHP exec() function. (This requirement may be relaxed in the future – see Reduce dependency on `exec` · Issue #7083 · pkp/pkp-lib · GitHub If you’re able, I’d recommend temporarily enabling the exec() function, installing the plugin, then disabling exec() afterwards.

Alec Smecher
Public Knowledge Project Team

Thanks a lot for your kind response. I ll do as directed.