PKP PN Plugin does not work #2

Hello everyone, everything good?

After the information and many interventions in the previously opened topic PKP PN Plugin does not work, the plugin is configured in config.ini and it is still not working. Previously, we had only one magazine, today we have 2 more, totaling 3 magazines and the problem persists.

OJS 3.3.0.8
PKP PN Plugin version 2.0.4.2
URL: https://periodicos.ifma.edu.br/redesign
URL: https://periodicos.ifma.edu.br/actatecnologica

Here are some scheduledTaskLogs PKP PN Plugin: https://drive.google.com/drive/folders/1aKOqfZCbCtPiEHVdKkm57wy4ZNwNIRFx?usp=share_link

I hope you can help me and solve this problem that has been haunting us for so long.

Hi @lcbrito02!

The last message on the log should be something like Task process stopped. As it’s not there, it means an error is interrupting the whole process. We’ll have to understand what’s exactly causing the error.

Can you share some error messages from your server’s error log? The messages that happened around the task execution are enough, if you’re not sure which ones to include (due to time zone configurations), just send all messages from yesterday.

Best,
Jonas Raoni

But unlike before, now package deposit is being done but nothing happens.

I’m waiting for a response from the server administrator. Will ship here soon.

1 Like

PHP Error Log: logs-php-28.03.2023.txt - Google Drive

Thanks! I see you’re affected by this issue: Database is missing a field · Issue #35 · pkp/pln · GitHub

The next release of the plugin should auto-correct it, but while it’s not released, you can fix this issue by asking your IT support to run this query against the database:

ALTER TABLE pln_deposits ADD export_deposit_error VARCHAR(1000)

I also recommend you to upgrade your installation to get the latest fixes :slight_smile:

Best,
Jonas Raoni

Great!
I will request the execution of the command and return here.
Thanks!

1 Like

Hi Jonas!
After executing the suggestions, the plugin gave life and started to work, however, it presented some different errors in the 2 journals that have active publications and I confess that we still don’t know how to solve them.
Below are the screens with errors, php logs and PKP PN plugin.

Logs:

PHP Error Log: logs-php-31.03.2023.txt

PLNdoPKP-Tarefadedepositante-64268b4d8dea8-20230331.log

PLNdoPKP-Tarefadedepositante-64268b7a6c010-20230331.log

PLNdoPKP-Tarefadedepositante-64268b750f80a-20230331.log

PLNdoPKP-Tarefadedepositante-64268ba32671a-20230331.log

Thanks again!

Hi @lcbrito02,

There are two problems:

[re]Design
The deposit was made probably from a test installation http:/​/​localhost:8888/​ojs-23.01.2023/, this isn’t going to work, our server should be able to access your installation.

Acta Tecnológica
This is the issue which affected you: Fair Copy files not migrated when upgrading from OJS 2 to 3 · Issue #7470 · pkp/pkp-lib · GitHub.
The fix will probably come out in a couple of days, but it will require you to upgrade to the new OJS 3.4 (not released yet), an easy fix would be to run this query against the database:

UPDATE submission_files SET file_stage = 6 WHERE file_stage = 7;
UPDATE submission_files SET file_stage = 9 WHERE file_stage = 8;

Best,
Jonas Raoni

About [re]Design, this was because I have a local test application that I ran first. Then the person responsible for the server did the same and the package was sent correctly.
However, the token and deposit information did not appear on the https://issn.org/ or https://keepers.issn.org/ website.

They will still execute the code related to the Acta Tecnológica

Hi!

However, the token and deposit information did not appear on the https://issn.org/ or https://keepers.issn.org/ website.

That’s expected, we’re solving an issue within the nodes that are part of the network, and until that’s solved, the status won’t be updated to “Completed”.

Best,
Jonas Raoni

This topic was automatically closed after 31 days. New replies are no longer allowed.