PKP PN not working

Description of issue or problem I’m having:
I’ve been having problems with PKP PN working for a long time, but it still doesn’t deposit; does not connect.

What I tried to resolve the issue:
works correctly

Cron and Acron
zip archive
xml native

Application Version - e.g., OJS 3.1.2:

3.3.0.10

Additional information, such as screenshots and error log messages if applicable:

Is there a configuration that I am missing?
Someone who is working could pass me the information on how it is configured so that it works
Thank you very much

@Nicolas_Salvi!

Please provide us the journal URL, we’ll use it to gather extra information from our side.

Does your journal have any firewalls blocking internal and/or external access to the internet (this plugin is supposed to contact the URL https://pkp-pln.lib.sfu.ca and the inverse communication path might happen as well, so services such as the Cloudflare firewall could be blocking it)?

Besides this, the journal should have an ISSN, the plugin should be enabled and you should have agreed with the service terms, accessible through the plugin settings.

If everything is fine until here, could you please take a look in your logs?

The PLN plugin works through a scheduled task, and its activity is logged in the directory ${files_dir}/scheduledTaskLogs (the location of the files_dir is configured in the file /config.inc.php) each time it runs. The PLN log file begins with the name PKPPLNDepositorTask and ends with a date stamp. If you don’t have these files, it’s an indication that the plugin may not be running as it should.

In order to extract a helpful error message, it would be great if you could:

  1. Execute the task manually using the command below:
    php tools/runScheduledTasks.php plugins/generic/pln/xml/scheduledTasks.xml

    The task is scheduled to run once a day, in case it has already been executed, it won’t execute again in the same day. Then you’ll need to set its last_run date back a few days in the scheduled_tasks database table.

  2. Share the latest log generated for the task (the one which starts with “PKPPLNDepositorTask” and ends with the current date)

  3. Share relevant errors from your server’s error log (the errors which happened in the time frame of the task execution)

Best,
Jonas

1 Like

dear jonas
Thank you very much for the reply
The URL of the magazine is:
https://rtyc.utn.edu.ar/index.php/rtyc/index
The system staff is verifying the information you previously sent us
Thank you very much

Thanks! On our end everything seems to be fine, the journal is registered, the terms are accepted and there’s an ISSN. Just missing the deposits.

Best,
Jonas

Hi! I’m having the same issue. My OJS has 11 journals, and only one journal is showing this in the plugin:

image

the other journals are looking like this:

image

The schedule task is running every morning at 1:30 as shown by my database:
image

However, my ${files_dir}/scheduledTaskLogs/ doesn’t have any log for this task, also, there is no error in my php error logs about this.

All my Journals have an ISSN, the plugin is enabled in every single one and we’ve agreed with the service terms of the plugin.

¿Do you know what could be happening?

Hi @Juan_Lopez!

Could you please move your message to a new topic? I’m not sure you have the same issue yet, so we’ll just create extra noise here with the investigation :slight_smile:

Also, be sure you’re including the journal’s URL and the versions of OJS and the plugin.

Best,
Jonas

1 Like

Dear, the systems manager informs me that I perform the following tests:
According to these results, can they guide us to solve the issue? Thank you very much

If from the console I do a “curl -I https://pkp-pln.lib.sfu.ca” it returns no route to host, this could be interpreted as a routing issue or a permissions problem but the same command to google It brings me the headers so I rule out a permissions problem, a curl to verify the ip gives me the correct ip and a ping to pkp-pln.lib.sfu.ca arrives correctly, so my conclusion would be that this server is not listening on 443 which is the https port. The Apache error log file does not change when the scheduled tasks are executed with the indicated command, the jobs table of the application is empty and the event_log table has messages that indicate submission.event.fileUploaded or submission.event.lastRevisionDeleted.

Hi!

It was a typo, it should be HTTP://pkp-pln.lib.sfu.ca (coincidentally the HTTPS has been enabled for this domain yesterday and we’ll update the plugin to use it).

As far as I can remember, the event_log isn’t being used by the plugin, the jobs table isn’t used as well, only the scheduled_tasks.

Also, as I said, if the deposit task has been running, there should be a log file for each execution in the folder “${files_dir}/scheduledTaskLogs” (files starting with the name PKPPLNDepositorTask), we’ll need the content of the latest one to inspect what’s happening.

Best,
Jonas