PKP PLN Plugin installation problem

Describe the issue or problem
Please tell us what happens and what you expected to happen.
I have read several threads concerning problems with this plugin. I am facing a similar problem. The plug in did not present in my list of plugin, so I tried to install it from gihub. (GitHub - pkp/pln: PKP Preservation Network Plugin). I installed the code (HTTPs, ZIP). I tried to uploaded to my journal plugins using website settings/upload a new plugin. And also by upload to File manager. Both led to the same problem, ¨Failed Ajax request or invalid JSON returned.¨ I saw in other thread that I have to run (composer install at the main plugin folder) which I did not understand what it means exactly. I would be grateful if someone can explain this.

I also saw on another thread that I should ¨Run the command php lib/pkp/tools/installPluginVersion.php plugins/generic/pln/version.xml at the main OJS folder¨. I am not that expert with this. I tried to look in the internet for explanation. I tried using PuTTY and WinSCP to get to the OJS folder and run the command but nothing worked for me. Again I would be so grateful if someone can explain this in detail and what software I may need to do it.

Many Thanks

What application are you using?

Hi @mazenhammadi,

The plugin was not released for OJS 3.4 yet. The updates are ready, but waiting for a code review here: Feature/main/57 support latest release by jonasraoni · Pull Request #84 · pkp/pln · GitHub.

Once the updates are approved, you’ll see the plugin on the Plugin Gallery.

Jonas Raoni

1 Like

Hello @jonasraoni ,
Thank you for your reply. Waiting for the updates.

This topic was automatically closed after 29 days. New replies are no longer allowed.