Our OJS 2.4.3 website suddenly died

Hi all.
I’m Francesco from Praise Worthy Prize Publishing House.
Our journals are managed with an OJS 2.4.3 website.
Still yesterday all were working fine. Suddenly the system doesn’t work at all.
I can’t really understant why.
The website of one of our journals is:

It seems that the link to the database has some problems in some situations.
Please let me know if you have some idea about this issue.

Thank you for your help.

Hi @Francesco1

Check your PHP error log for details…
maybe something have change in your server environment?

From the web console the error is Failed to load resource: the server responded with a status of 500 (Internal Server Error)

So need to check your configuration if something change…


Thank you @mohd_arshad for your kind reply . I have no notice of changes in my server provider configuration. Just for one of the journals I tried to disable in the database all the plugins and the home page now is working but for the same journal the System plugin setting page doesn’t work at all. I can’t understand the reason of this sudden issue. I would try to setup the plugins in the database but I’m not sure of the tables I have to check. Thank’s again


Hello @Francesco1.

have you protected files_dir ?

find . -iname *.phtml 

If you have a dump from database

vim database.dump.sql

Esc + /<script + Enter

I think that would be good upgrade to 2.4.8-5

and, check users table for bots.

You better make scheduled backup to your journal such problem may be solved easily on the future and to keep your data safe @Francesco1 .

1 Like

Hi @juanito and @navotera thank you very much for your kind answer. Just to inform you now the website is ok. I disabled all the plugins and managed the database but I think that there had been some problem by my hosting provider. Really I’m still confused about what really happened. Anyway now I’m scheduling to make a backup of database and files and we are programming to pass to a newest version of OJS.
Thank’s again,

1 Like