ORCID plugin won't allow author to connect and authorize

Hello! I’m looking for some help with the ORCID iD plugin.

I’m trying to run through the ORCID iD plugin sandbox tests and running into problems. Has anyone else had any luck fixing either of the following issues?

I’m using
OJS version:
ORCID iD Plugin version: 1.1.1-12

  1. When attempting to authorize and connect a user’s ORCID iD the link connects to the ORCID sandbox, I accept the request, but on the user page in OJS it just keeps saying “authorize and connect your ORCID iD.” (see screenshot)

ORCID screenshot 1

  1. When I send an email to an author to connect an ORCID iD, the email gets sent to the mailinator address used for sandbox testing, but when I click the emailed link I get an error that says “The ORCID authorization link has already been used or is invalid.” (See screenshot.)

ORCID test 4 error 2

Hi @kcawthorn,

Curious if you’ve looked at our ORCID documentation appendix: Appendix: Testing the ORCID Sandbox and tried some of the suggestions offered there?

Additionally, we have some forthcoming changes to the ORCID plugin coming in the next few months that should simplify the process of setting it up (this will be announced on the PKP blog when available). If you stand to afford to wait to save yourself from having to troubleshoot - you may want to see these changes and update your plugin to the latest version that takes advantage of the new features.

PKP Team

1 Like

Hi Roger! John here from the Working Group. I’ve been troubleshooting with Kate, and we cannot seem to identify the source of the error. I’ve worked with a lot of members and never run into this issue before. We tried to work through the scenarios, but nothing came of that - same error every time, in every situation. There appear to be two connected problems:

  1. The authorization is not working: Everything about the plugin is active and functional (on the Sandbox) until someone tries to connect an ORCID iD by email. When they click the link, they are asked to sign in to authenticate and then authorize OJS permissions as usual. The error occurs when clicking “Authorize”. As Kate showed in the screenshot, it redirects back to OJS and displays error in red (“the ORCID authorization link has already been used or is invalid”).

  2. For some reason, although no permissions are officially granted on the ORCID side (i.e., this does not wind up making OJS a “Trusted Organization”), it does seem to do something - it suddenly lists “https://orcid.org” as the connected ORCID iD.

Any guidance on this from the technical folks would be very much appreciated. Is there anything else PKP might need here (e.g., logs)?

Hi @kcawthorn @JAspler,

Tagging @Dulip_Withanage here who may wish to weigh in (but he is currently away and may not be able to respond).


1 Like

Hi @rcgillis,

Thanks for the rapid reply, and for tagging in Dulip!

The link you sent along does seem to mention a plugin version, unless I am misreading this section, compatible with OJS and released just a few weeks ago. (My understanding is that the versions of the plugin labelled 1.1.1.X are for OJS 3.1.2.X, while plugin 1.1.2.X are for OJS 3.2.X).

	<release date="2021-02-28" version="" md5="a0fb6fd1295fde47300963d286014bca">
		<compatibility application="ojs2">
		<certification type="official"/>
		<description>Disable for  site-index, disable by cleint Id and secret errors</description>

Hi @JAspler,

You’re right - I missed that, and I do see that this release is supposedly compatible with the version of OJS that is being used. But speaking to those issues that you’ve identified may have to wait until @Dulip_Withanage is available to address them.

PKP Team

Hi all! I was wondering if there had been any movement here, @Dulip_Withanage. Thanks all!

Hi @JAspler ,
I am sorry for the very late reply.
in your case, have you checked the link ontains "settings " in the link.
There was a tiny-mce issue, which was in OJS. But I fixed it.

Could you confirm it is not the case ?

Hi @Dulip_Withanage and @JAspler

Thank you so much for your reply! I can confirm that that does seem to be the issue. The additional ../management/settings/ before the {$authorOrcidUrl} shows up in the url link in the current ORCID email templates. Is this something that we can fix manually at the moment, or it is something that will be resolved once we upgrade to 3.2?

Thanks very much,

Hi Kate,
this was fixed on Remove script host from smarty variables · Issue #6344 · pkp/pkp-lib · GitHub
yes, after 3.2 versions on last november, you will have this fix in ojs.

Hi Dulip,

Great! Thank you very much for this information. We are planning an upgrade for all of our hosted journals in the near future, so that works out great.


Hi Dulip - thank you so much for your follow-up here; I’m delighted this issue will ultimately be resolved once the migration to OJS 3.2 happens.

On broader question this raises for us: Does this mean that the plugin may display this error for any institution running OJS 3.1.2.X? Is this an issue specific to Thanks so much!