Open typesetting not woeking


#1

I have installed markup plugin manually. However I am not able to see the ots settings. I’m working on OJS 3 and PHP7.0. also when I click on ots backlog conversions and select the files, it shows access denied. Please help


#2

Did you managed to make it working?


#3

Hi,
I am having the exact same problem, running a test version of OJS 3 on a local server. I’ve tried reinstalling OJS and inserting the OTS settings directly in my config.inc.php, with no luck so far!

All the best


#4

No, still not working


#5

I don’t think that it was updated to be compatible with the latest stable OJS release.


#6

It works without any issue on OJS 3.1.1-2, so the problem does seem to come from the latest release. The issue has been raised on the Github Markup repository (https://github.com/kaschioudi/ojs3-markup/issues/67#issuecomment-461771928)


#7

Do you see any errors in the PHP error log?


#8

Some warnings, 2 of them related to Markup, but no fatal error:

[12-Feb-2019 14:29:48 UTC] PHP Warning: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /Applications/MAMP/htdocs/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 386 [12-Feb-2019 14:29:48 UTC] PHP Warning: Declaration of MarkupPlugin::register($category, $path) should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /Applications/MAMP/htdocs/plugins/generic/markup/MarkupPlugin.inc.php on line 590 [12-Feb-2019 14:29:48 UTC] PHP Warning: Declaration of MarkupPlugin::getTemplatePath() should be compatible with Plugin::getTemplatePath($inCore = false) in /Applications/MAMP/htdocs/plugins/generic/markup/MarkupPlugin.inc.php on line 590 [12-Feb-2019 14:29:48 UTC] PHP Warning: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /Applications/MAMP/htdocs/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 19 [12-Feb-2019 14:29:48 UTC] PHP Warning: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /Applications/MAMP/htdocs/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 19 [12-Feb-2019 14:29:48 UTC] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /Applications/MAMP/htdocs/cache/t_compile/cc87c37be02cfb67c21f370fae28834e2716951e^%%40^408^4081C66E%%footer.tpl.php on line 37