Omit author's name in notifyusers mail


When I select “Omit” in Edit Metadata as shown below, the author’s name is not displayed in the Table of Contents as expected…

but when I notified the users regarding the publication of new issue and mark the box “Include the table of contents from this issue”, the mail is sent with the author’s name. There is some way to send the mail without the author’s name in the table of contents?

Hi @rauf,

I think this is a bug. The table of contents page is checking the hide author submission setting, but the template that’s used to render the table of contents in the email notification is not.

Right now you can only hide all the authors by setting the section hide author setting, in the section editing page. But this is not perfect because you can’t define the author visibility at a submission level, like you can in the table of contents page.

I created an issue so we can track this bug: Submission metadata omit authors setting is not working when notifying users and including TOC · Issue #720 · pkp/pkp-lib · GitHub. If you want, you can follow that to get updates.

Thanks for your report. :smile: