OJS3 installed but with issues


Impatient to see the new versions and already seen already installed, but unfortunately not fully tried yet because of some errors.
Here is quickly my first experience with OJS3 in a nutshel:
After loging in as admin, I try to ‘create a journal’, by providing a Journal title, Journal description and a path. Then, I click “Save”, but the system freezes and nothing happens even after long minutes of waiting.
When I click on the Administration link (at left), a page with ‘Site Administration’ label appears.
In this page, I see “Site Management” under which “Hosted Journal” appear.
When I click on this (Hosted Journals link), I see only the path’s name of the journal I have already created after logging in as an admin. The field of the Journal’s title appears empty beside a blue arrow, though I have provided the title and description in the first step of the journal creation page.
Then, I click on the small blue arrow, supposedly pointing to the journal name, and I see three options:
Edit, Remove and Settings wizard.
I first selected “Edit”, and then, the page of ‘Create Journal’ appears again, but this time without the text toolbox that seemingly disappeared at this stage.
I fill again again the same info as previously (journal title and description), and click ‘Save’ again, and the journal name now appears alongside the path.
Then, when I click on the option “Settings wizard”, nothing happens but a Loading circle that turns permanently and an error message poping up with the following error:

The page at localhost says:
The current role does not have access to this operation.
Prevent this page from creating additional dialog.

When I click on “View Site” on the top right, near the admin login, I have a new deformed page that appears as follow with the supposedly journal elements but stacked on the top left:

This does not look like a journal page.

This is all what I could see/test so far, after installation. I hope this would help fixing these errors. Unfortunately, I couldn’t go further than these few steps. I’ll try again later to see if I could go to other steps.

Thank you again for your efforts.



Hi @Bupeer,

When you attempted to create the journal, an error occurred, and I suspect the other problems you encountered stem from that. Check your PHP error log to see if there are details from around the time you created the OJS journal; these should help debug.

Alec Smecher
Public Knowledge Project Team


Hi Alec,

Thank you for your reply.
My PHP log (in WAMP server) is empty.
Other PHP-based tools works just fine and I did not have any error.
The installation operates fine but the issue starts from creating a journal; once I click on “Save”, this turns into gray and nothing else happens except a circle turning in permanence at the down-right corner of the screen.
This took more than 20 minutes!
I then clicked on ‘Cancel’ and found the other issues described above.
It would be much appreciated if the system was able to tell what/where the problem was!


Hi @Bupeer,

Do you have a browser-based developer tool like Firebug for Firefox? If you see an endless spinner, it generally means a sub-request failed. A developer tool can help by letting you inspect what the system sent back to the browser; this might contain the error message.

Alec Smecher
Public Knowledge Project Team


Hi Alec,
Thanks for the prompt response.
Yes, I have but I am not a developer, so I do not know exactly how to use it properly or where should I look to find the errors.
Anyway, after I click on “Cancel” and go back to the Administration panel, and created a new journal with exactly the same errors as for the first journal created, now I see a “Submission” link just above the Administration link.
When I click on it, I have the submission page appears but it seems that the language and section choices are Mandatory to go through the other submission steps but these fields are empty!
So, the submission process is immediately stopped here!
The other steps (upload files, metadat…) are obviously inaccessible as the first one was not accomplished.
Please check the screenshot:

As you can see at the top right screenshot, there is only English, so I do not know why the option of Submission language is there! And even if it is there, this should be optional!
The same for the section, it is mandatory but empty too!


Hi @Bupeer,

The problems you’re describing stem from an incomplete installation – there’s definitely a PHP error message hiding somewhere. Your log should at least have warnings in it. Can you double-check? You can use your phpinfo() output to locate logs if you’re not sure where errors are getting logged.

Alec Smecher
Public Knowledge Project Team


Thank you Alec.
I have reinstalled (clean installation) but the same problem persists. The PHP log is still empty.
However, when I check with the developer tool, I found the following message under the ‘Network’ tab:
cs.js:321 ‘Range.detach’ is now a no-op, as per DOM.

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check http://xhr.spec.whatwg.org/.

Could this be the cause? Any fix?



Hi @Bupeer,

Neither warning should cause problems – though you can resolve the one about LuceneAutocompleteHandler.js by applying this patch. Would you be willing to share access credentials to your server? If so, send me a private message with details.

Alec Smecher
Public Knowledge Project Team


Thank you Alec.

I am still testing in a localhost server, so it would be hard that you can do something online as my installation is not online yet.
I have already make a third new installation after I deleted all the other installations including the beta one and after I deleted the corresponding databases, but still have exactly the same problem.
From the start, when I try to “create a journal” and click save, the system turns permanently and then I have all the other issues described above.
I am running windows 7, WAMP (PHP 5.3, APache 2.2, MySql5.5).
Somewhat disappointed…as I can install wordpress, drupal, and many other cms without any particular problem.


I too have this problem with two installations on xampp local servers. Cannot find any error logs on this issue. The only active user in the system is the admin user created at installation, and it does not have any rights, except for registering as author.
The only two panels I get on the left are Tasks and Administration.

What could be wrong with the installation? 2.4.8 worked like a charm, out of the box.

Best regards,



Hi @mindseeds,

We haven’t tested OJS 3.0 with XAMPP, so it’s entirely possible that an assumption has made it into the release about e.g. Windows vs. UNIX conventions. I don’t have a Windows machine here to test/debug on, but will see if someone else on the team can take a look.

Alec Smecher
Public Knowledge Project Team


Hi @asmecher,

I tried doing five installs in 3 differents machines, with OS Windows with xampp,wampserver and easy php, and not working. Is the same error.


Hi @cgaravito,

Can you ensure that your max_execution_time limit in your PHP configuration is greater than 30 seconds? It may take up to a minute to install OJS on Windows machines – to be safe, extend it to a few minutes. See http://stackoverflow.com/questions/5164930/fatal-error-maximum-execution-time-of-30-seconds-exceeded
for details on how to accomplish this. Be sure to restart the service after increasing the limit.

Alec Smecher
Public Knowledge Project Team


Hi @asmecher,

Thanks! I configurated the max_execution_time in 120 and ojs v3 are running so good!


Hi @cgaravito,

Excellent, glad to hear it!

Alec Smecher
Public Knowledge Project Team


I confirm, it works by extending the max_execution_time in the php.ini file to a larger value than the default one provided by the server (i.e. Wamp).

However, after installation and completing the other steps, the text in the Abstract seems to exceed its specific field by overlapping with the citation block at the right as it could be seen in the following screen shot:

Actually, the text extends to the right indefinitely in one line only. I should continue to scroll horizontally as long as there is a text to read!
The page set up seems to be broken?

Any tip to fix this?

Thank you


Hi @Bupeer,

Can you send a link to a journal where this is happening? I see spaces in your content which should cause the text to wrap, but it’s possible there’s actually a weird character encoding artifact of some kind going on.


Dear all, Please someone could help us. We installed a new version of OJS 3.0 with success. But, I am looking for the “Quick submit” plugin that I have use a lot to update our Journal content. Please, could you tell me how to use it in this version 3.0, or how to install it ?. Thanks



Could you post your question as a new thread? It’s not related to the above thread. That’ll help keep the forum organized.

Alec Smecher
Public Knowledge Project Team


Hi, I’m having the exact same problem as OP. I tried extending the execution time of the PHP but it didnt fix anything. ¿Any other ideas? The errors I’m encountering are the following in the apache log

[Sun Nov 13 12:26:24.962261 2016] [:error] [pid 7040:tid 1660] [client ::1:53303] ojs2: 404 Not Found, referer: http://localhost/ojs/index.php/index/$$$call$$$/page/page/css
[Sun Nov 13 12:27:07.984721 2016] [:error] [pid 7040:tid 1652] [client ::1:53311] PHP Warning:  mkdir(): No such file or directory in C:\\xampp\\htdocs\\ojs\\lib\\pkp\\classes\\file\\FileManager.inc.php on line 303, referer: http://localhost/ojs/index.php/index/admin/contexts
[Sun Nov 13 12:30:34.325523 2016] [:error] [pid 7040:tid 1644] [client ::1:53367] PHP Warning:  file_put_contents(C:\\xampp\\htdocs\\ojs\\cache\\fc-journalSettings-11.php): failed to open stream: Permission denied in `C:\\xampp\\htdocs\\ojs\\lib\\pkp\\classes\\cache\\FileCache.inc.php on line 90, referer: http://localhost/ojs/index.php/trabhiscrit/admin/contexts?openWizard=1`

I already changed the permissions of the htdocs so it has full control. Don’t really know what else to do.

Thanks you for the help