OJS3: Cannot view the Full issue galley

Hi! I’m trying to create a full issue galley (PDF). It is displayed as such on the issue page. But when I click on it, nothing happens (the page just reloads).
I can view all the article galleys, except the full issue.

Another strange issue is that I cannot upload any file at one try. When I choose the file for the first time, nothing happens, so I always have to choose twice to upload it.

1 Like

Hi @Ph_We,

Thanks for reporting – have a look at Fix text paths for issue galleys · Issue #1801 · pkp/pkp-lib · GitHub and try applying one of the two patches linked there (both are equivalent, just committed to different branches).

For the double-upload issue, can you check your browser’s console to see whether you’re encountering a Javascript error?

Alec Smecher
Public Knowledge Project Team

Thank you very much, Alec. Unfortunately, I cannot test it right now, but hope it will work.

As to the double-upload, I can only reproduce it in Chrome. When the page loads I get these errors:

website:13 GET http://.../plugins/generic/lucene/js/LuceneAutocompleteHandler.js
website:13 GET http://
.../plugins/generic/lucene/js/LuceneAutocompleteHandler.js 404 (Not Found)
jquery.min.js:4 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.
jquery.min.js:4 GET http://
...**/index.php/vanin/$$$call$$$/page/page/@%7BbaseUrl%7D/lib/pkp/templates/images/structure/icon_globe.png 404 (Not Found)

But there are no errors when I try to upload a file (for both ‘attempts’)…

Hi @Ph_We,

Hmm, none of those should be causing the problem you describe, I don’t think. Would it be possible for you to PM me with temporary credentials so I can try it myself?

Alec Smecher
Public Knowledge Project Team

Hi Alec,

Please see the PM. Thank you!

Good day.

I confirm issue with double upload.

on page view source I see only errors, discussed above.

1 Like

Hi Vitaly,

What browser do you use?


I use Chrome mostly.


Are you on shared hosting? Do you have access to your site files manager? If so, you could try to see whether the file is actually uploaded by going to the full issue galley file location at “files_directory”/journals/(journal_no)/issues/(issue_no)/public/xx-x-PB.pdf ?


Hi all,

has this been solved? I have the same problem…

I read all replies on this page, and I do have PDF uploaded in “files_directory”/journals/(journal_no)/issues/(issue_no)/public, but it won’t open on the issue page…


Sorry guys, found it.

Fix is here: Fix text paths for issue galleys · Issue #1801 · pkp/pkp-lib · GitHub

Hi everybdy, I got the same problem. Tried the patch but it did not work. And also note that my lib/pkp/pages/… directory did not have “issue” folder. I had to create it. Am on ojs 3.0.0 upgraded from 2.8

Hi @otuya1

So much bugs were fixed since 3.0.0 so that it is worth upgrading to the most recent version…


Thank you @bozana …I think i just fixed it. I will consider upgrading tho