OJS Plugin Installation Error: "Plugin Installation Failed: Could not extract plugin"

Hello PKP community,

I’m encountering an issue while trying to install a plugin in Open Journal Systems (OJS) and I’m hoping someone can provide some assistance or guidance. Every time I attempt to install a plugin through the Plugin Gallery or manually upload the plugin file, I receive the following error message: “Plugin Installation Failed: Could not extract plugin.”

3. I’ve followed the standard procedure for plugin installation, either by searching for the plugin in the Plugin Gallery or by manually uploading the plugin file.
4. The error occurs consistently regardless of the plugin I’m trying to install.
5. I’ve ensured that the plugin files are properly formatted and compatible with my OJS version.
6. I’ve tried installing the plugin on multiple OJS installations with the same result.
7. There are no permissions issues preventing the plugin files from being extracted during installation.
8. I’ve checked the server error logs, but there are no relevant error messages recorded.
9. Other functionalities within OJS are working as expected; this issue seems to be specific to plugin installation.

Potential Questions:

  1. Has anyone else encountered similar issues with plugin installation in OJS?
  2. Are there any specific server configurations or PHP settings that could cause this “Could not extract plugin” error?
  3. Could this be related to file permissions or ownership of the plugin directory?
  4. Is there a recommended workaround or alternative method for installing plugins in OJS to bypass this error?
  5. Are there any known compatibility issues between certain plugins and OJS versions that could trigger this error?

Any advice or insights into resolving this plugin installation issue would be greatly appreciated. Thank you for your help!

Hello @joeroot !

You may want to check your config.inc.php file to see if the ‘tar’ option is pointing to the system’s tar application correctly

Yes, it might be related. ‘plugins’ directory and all it’s subdirectories should be writable by the webserver (in Linux, tipically the www-data user)

Not all plugins work on all OJS versions… but if you find them in the plugin gallery they should be compatible and work without problems, as far as I know

Hope that helps! :slight_smile:

Thank you for your response and suggestions! I’ve checked the config.inc.php file and ensured that the ‘tar’ option is correctly pointing to the system’s tar application. Regarding permissions, I’ve confirmed that the ‘plugins’ directory and all its subdirectories are writable by the webserver user.

I understand that not all plugins may work on all OJS versions, but I’ve encountered this issue with multiple plugins available in the plugin gallery, so compatibility shouldn’t be the issue here. Given that the permissions and ‘tar’ configuration seem to be in order, is there anything else I should investigate or try to resolve this “Could not extract plugin” error? Appreciate your continued assistance! :slightly_smiling_face: :smiling_face_with_tear:

Hi @joeroot,

What version of OJS are you using? Can you confirm the exact error message you’re seeing? (I’d like to identify the exact line of code that’s throwing the error message, but I don’t see that exact text in the codebase. If you’re e.g. translating the message from another language, post it in its original form.)

Alec Smecher
Public Knowledge Project Team