OJS issue, articles can't be reordered

Description of issue or problem I’m having:

In this case, users have noticed that they are unable to switch the order around in the upcoming issue that will be published soon.

Steps I took leading up to the issue:

go to this url https:// → journalhosting.ucalgary.ca/index.php/arctic/manageIssues

ex:

So below link in will take you to the section I am trying to change

https://journalhosting.ucalgary.ca/index.php/arctic/manageIssues

I am logged in as admin user which is a username with journal manager privileges

Then click the blue link under “future Issues” that says Vol. 74 No. 4

The window that opens - “table of contents” is where you want to be

On the right hand side there is a button that says “order”

Click that and then you will see up/down arrows beside all of the sections

“book review” section should be just after the “notes” section

Once you move that up, at the bottom of the pop-up window click the “done” button

This is when the section I’ve just moved jumps back to just under “letters to the Editor” .

What I tried to resolve the issue:

Read and followed this post

try turning on and off config param: enable_minified = On/Off

Application Version - e.g., OJS 3.1.2:

just upgraded from ojs-3.2.1-4 to ojs-3.3.0-8

Additional information, such as screenshots and error log messages if applicable:

You will see javascript warning in this attachment.

re-order

Thank you for any help!

Dung.

Hi @dung

If the sections must be in this order in all issues, try this path:

Settings > Journal > Sections > Order

Reorder as desired and click Done.

Does it solve?

Hello @abadan ,

Thank you so much for getting back to us. Your procedure works but that was not the problem we encountered as described.

Please see this attachment.

re-order2

Can you still help us with the original question?

Best,

Dung.

Also with your method I found DOM error below:

re-order3

Too bad it didn’t. We have some cases where reordering the sections in the place I indicated solves them within the issues.

In this case, I suggest analyzing the old posts on this forum on this subject, being a little frequent. Probably the solution will now depend on editing the database, after an additional backup.

An example approach:

Thankyou @abadan for sure I will try that and report back the result.

Best,

Dung.

Hello @abadan , it is good news that the link you gave helped me resolved my issue :slight_smile:

And I have also contributed some notes to fit new version 3.3.0-8 as pasted below:

Thank you so much @abadan for the pointer!

Best,

Dung.


Thank you @claivaz !

I followed your instruction and it was a bit hard to identify the “section_id”, “issue_id” but I figured it out as shown in attached screenshot. It works!

Much appreciate your sharing.

custom_section_orders

Best regards,

Dung.