OJS installation, install script error

Hi there,

Unfortunately, I am asking about the same thing again that I did about 10 months ago …

I try to run the tools/install.php from the command line to install the OJS and run into the following problem:
Screenshot from 2021-05-12 15-44-02

I can’t remember how I got past this issue back then. Do you have any pointers?

Thanks very much
Philipp

OJS is telling you that your server lacks of xml support.

The explanation is in the post you link (error “undefined function xml_parser_create()”).
There you can fin a link to a detailed explanation in stackoverflow:

From there, stack links to the solution for php 5.x.

In short, for php5: You need to install “php-xml-parser”:

$ sudo apt-get install php-xml-parser 

Depending on your php version or operating system, the library could be named a little different.

For instance, for php7 on debian/ubuntu, you can install it as follows:

$ sudo aptitude install php7-xml

Cheers,
m.

Thank you for your help Marc!
I was able to install OJS successfully from the command line:

Screenshot from 2021-05-13 10-05-36

However, I am getting a fatal php error when I try to run the index.php file:

Screenshot from 2021-05-13 10-14-24

Best
Philipp

Do you mind to post errors in text mode?
It makes easier to cut& paste.

And is better if you post a few lines more to get the context.

Did you try to search this error in this forum or in the web?

My guess is OJS is yelling now due a DB issue: Wrong charset or wrong driver.

Hi Marc,

Sorry about that, here is the error I am referring to:

PHP Fatal error: Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1115 Unknown character set: ‘’ in /var/www/ojs/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:78

Oppss… :slight_smile:

The searcher is your friend:

https://forum.pkp.sfu.ca/search?q=PHP%20Fatal%20error:%20Uncaught%20PDOException:%20SQLSTATE%5B42000%5D:%20Syntax%20error%20or%20access%20violation:%201115%20Unknown%20character%20set:%20%E2%80%98%E2%80%99%20in%20/var/www/ojs/lib/pkp/lib/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:78

BTW, why are you installing from the command-line?

Hi Marc,

Yes, I installed from the command line.
(I couldn’t get the browser version to work)

ph

Hi Marc,

Are you suggesting I adjust the config.inc.php as per the post you referenced?

ph

Yes I did… but now I feel we are taking the long road here.

Yes, I installed from the command line.
(I couldn’t get the browser version to work)

May be we need to start with this one?

If you can’t run the installer in web mode, something important is broken… and may be I’m wrong but installing it from the command-line won’t make any difference.

Hi again,

I had done an install of the OPS from the command line as well last summer and that worked fine.

I went through the command line installation of the OJS yesterday and got a confirmation that it had “successfully installed”. But when I tried to open the site in the browser I just got an empty page, hence my attempt to open the index.php file from the command line.
That’s when I saw the php fatal error.

What do you suggest?
ph

BTW, I am doing a local install on my linux box to kind of get a feel for how things work.
I will need to install OJS on a shared environment afterwards.
(same environment where I also installed the OPS)

Hi again,

I’ve made the change in the config.inc.php, but now I get a new fatal error:

PHP Fatal error: Uncaught Error: Call to undefined function mb_split() in /var/www/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/plugins/shared.mb_str_replace.php:47

I checked on my system, I already seem to have the newest version of mbstring:

php7.2-mbstring is already the newest version (7.2.34-21+ubuntu18.04.1+deb.sury.org+1).

ph

Hi again,

Should I try to uninstall and start over?
What would the steps be for a complete uninstall?

Thanks
ph