OJS Crossref DOI not working

We are having problems to get published the DOIs of our last issue. Export process seems have not problems, upload to Crossref is success and submission goes away from the queue, but DOI urls does not work… We are trying since July 1st.

We are running OJS and last issue worked fine, in January 2017.

At the administration area of Crossref platform I can see the following report:

<?xml version="1.0" encoding="UTF-8"?>
<doi_batch_diagnostic status="completed" sp="ds5">

Do you have any idea what could be the problem?

Kind regards,
Icono 14

Hi @celuloide

Your example DOI above is now functioning. Does it mean that the problem is solved?
Else, could you maybe ask Crossref support, if they could give you any further detail?


Hey @bozana,
Thanks for answering. Yes, it is solved. I leave here the explanation to help someone in the same situation.

Recently we changed the name of our journal on OJS settings to get shorter cites, but we did not notify that to Crossref, who had our ISSN associated to the old name. When we exported the xml to upload the DOIs, the name of the journal was not the same on Crossref, so it was not working.

The solution was to change back the name of the journal as previously was, then export again the DOI’s xml and it finally worked on Crossref platform.

So, we highly advise to notify Crossref if you want to change the name of your journal, even if it is a minor change.

Best regards,