OJS Acron plug in

Hi, I am setting up PKP PLN, which requires enable “PKP PLN Plugin” under “Generic Plugins”. The PKP PLN Plugin also requires enabling “Acron” plugin.

It seems that “Acron” only has two options “Enable” and “Reload Scheduled Tasks”. I enabled the “Acron” plugin, and it created a table named “scheduled-tasks”.

I could not find more documentation on how to configure it. Do I need to do any other configuration?


Hi @Y_H,

You just need to enable the Acron plugin and it’ll take care of scheduled tasks on its own without further configuration. However, if your service provider supports cron jobs, that’s a preferred configuration – in that case you’d disable the Acron plugin and configure cron instead. See config.inc.php for details.

Alec Smecher
Public Knowledge Project Team


I have a problem with Acron Plugin. When I reload scheduled tasks a blank page comes. I researched about Acron Plugin and saw that there is a different namd Acron Plugin else. “PKPAcronPlugin.inc.php” But I didnt find in forum nothing about this.

There is a strange view in Acron Plugin.

Is this normal?

it seems that you have copied files from another plugin to the acron folder?

No, unfortunately not. Normally I use OJS version files. Like this:

you could try first making a backup from the files you have at the moment in /bmij.org/plugins/generic/acron/

Then get the same version of OJS2 that your site using from the PKP dowloads page and replace the acron plugin folder you have with a new one.

Because it is clear that there are files from another plugin in your Acron plugin folder.

The other Acron plugin you mentioned is this one:

In OJS3 they have moved Acron to pkp-lib so that the same code is used also in Open Monograph Press.

Ok, I applied this. I reload the Acron Plugin a blank page comes.

did you check your php error log

usually a totally blank page will result into some sort php error. Maybe you could try turning on debugging from config.inc.php and the try to run the acron plugin? Or perhaps try deactivate acron from the plugins and the reactivate it?

Now the current setup is this. How can I change?

If you are getting a blank with a php application it should always mean that some sort of error has occurred.

Maybe you server settings are not allowing to show errors by default? Have you checked what the error_reporting setting is in your php.ini file?

Since your “error.log” file only references Apache errors (such as “file not found”), I suspect you have another dedicated PHP error log which will have a helpful error message. Check with your system administrator or hosting provider regarding where PHP error messages can be found.