[OJS 3] 'Upload a New Plugin' does not work

Hi! I’m trying to upload a new plugin from the back-end (customBlockManager). It says:

The uploaded plugin archive does not contain a folder that corresponds to the plugin name.

I tried both *.zip and *.tar.gz. What may I do wrong?

I used links from here: Releases · pkp/customBlockManager · GitHub

Do we need to install it again since it is already installed?
I tried upgrading it but the same notification comes up

One of our admins deleted this plugin and then tried to reinstall it by using ‘Upload a New Plugin’. But he failed. So we had to install it from the installation folder :pensive:

The folder name contained within the .zip and .tgz downloads is wrong. It should be just “customBlockManager”, not “customBlockManager-ojs-3_0_1-0” (or similar). Renaming the folder within the compressed file will allow the upload. See also:

This may be something we will want to workaround in the OJS codebase rather than fixing the release packaging process.

Hi @ctgraham,

Thanks, I’ve seen that post of yours. But in this case the folder name seems to be correct (see the archives here: Releases · pkp/customBlockManager · GitHub).

When I download a fresh copy, I see the problematic naming:

Ah, yes, sorry, that was my mistake. Now it’s clear.