OJS 3 - The current role does not have access to this operation

ojs3
ojs

#21

@asmecher,

Yes, it did!

Regards,
Rafael Mansilha.


#22

Hi @rafaelmansilha,

Excellent! I’ve read over @bozana’s take on this, and agree with her. If this solves your problem, then I won’t need access to a database dump.

Thanks,
Alec Smecher
Public Knowledge Project Team


#23

Hi,

I have the same error when the Author submitting a manuscript clicks the More Information link on an uploaded file.

I have a clean install of OJS 3.0.2 without any customization.

Thanks,
Luciano


#24

Hi @lpanebr

I am not sure, if this function should be there for an author, so I will double check…

Best,
Bozana


#25

I have the same problem on some reviewers when they try to open a file for review.
The message is:
{"status":false,"content":"The current role does not have access to this operation.","elementId":"0","events":null}
I have OJS 3.1.0.1, db PostgreSql and PHP 7.0
Are there any solutions to this problem? Will version 3.1.1 solve the problem and if so what is the associated issue?


#26

Hi @eniocarboni

Those cases should be solved. However if you give me the concrete example, we can see if it is just in your installation or general bug…

Best,
Bozana


#27

Ok, i try
As this particular reviewer login (or login as) then click on the submission to review and i see
immagine
When I click to open any of the files I get
immagine
There are, for now, 2 reviewers with this problem while others have no problem.
This revision, for now, is in the state “The rivision has missed the response due date”.
If needed, I can directly run queries in the db to get more information even if I can not send details to the db since they are data of a customer (like the complete dump)

Note to my OJS version history: installed 3.0.2.0 than update to 3.1.0.0 and finally to 3.1.0.1


#28

Hi @eniocarboni

Thanks a lot – I’ll take a look in my local installation… and will then come back to you…

Best,
Bozana


#29

Hi @eniocarboni

OK, I think I figured it out: You have the following journal setting: “Reviewers will have access to the submission file only after agreeing to review it.” (Settings > Workflow > Review > Reviewer Access (at the end of the page)). Because that reviewer haven’t accepted the review he/she still cannot access the files. Thus, first the reviewer will have to accept it in the review step 1 (“1. Request”) and then he/she can continue further…

Best,
Bozana


#30

Hi @bozana,
yes, this is the situation.
The reviewer has not yet agreed to do the review.
Ok, but why by clicking in the submission (from the dashbord) does the reviewer go directly to step 3 instead of being stuck in step 1?
However, I will ask my client if he can get the review accepted and see what happens. I’ll update you as soon as it’s done.


#31

Hi @bozana,
I test all in my local installation and yes if the reviewer accept the review in step 1 then all ok.
But, this is the original row of SQL of this submission_id and reviewer_id:
select * from review_assignments where submission_id=34 and reviewer_id=219;
-[ RECORD 1 ]----------±-------------------
review_id | 109
submission_id | 34
reviewer_id | 219
competing_interests |
recommendation | 0
date_assigned | 2018-04-13 10:25:48
date_notified | 2018-04-13 10:25:48
date_confirmed |
date_completed |
date_acknowledged |
date_due | 2018-05-04 00:00:00
date_response_due | 2018-04-20 00:00:00
last_modified | 2018-04-13 10:25:48
reminder_was_automatic | 1
declined | 0
replaced | 0
reviewer_file_id |
date_rated |
date_reminded | 2018-04-21 00:00:03
quality | 0
review_round_id | 27
stage_id | 3
review_method | 2
round | 2
step | 3
review_form_id |
unconsidered | 0

As you can see we are in step 3 and not in step 1 even if “date_confirmed” has not been clicked.
How is this possible? Do you think there may be a user or editor operation to make this change? Or something associated with the expiration of the reviewer’s response time?
If I change, through SQL, from “step = 3 to step = 1” (always in my local installation) I have seen that I return to the ideal situation. Do you see any contraindications to do this in the meantime that someone understands the reason for the incident?


#32

Hi @eniocarboni

Hmmm… yes… I’ll investigate how this could happen… will then come back to you again…

THANKS!!!
Bozana


#33

Could someone confirm that there are no contraindications if I change the “step” field from value 3 to value 1 via SQL?
In this way I could give a temporary solution to my customer.
Thank you very much


#34

Hi @eniocarboni

I cannot see any place in the code that could cause such a problem :stuck_out_tongue: Were those steps maybe already wrong in the OJS 2.4.x DB?

I think it is OK to change those values from 3 to 1 – they are only used in that reviewer submission backend, and to forbid the access to the further/bigger steps…

Best,
Bozana


#35

Hi @bozana
thanks for the reply.
I will try to understand the problem better and if it occurs again I will try to contact you again


#36


Hi guys, can anyone help me with this?
I’m sorry I’m just a newbie for OJS. I was trying to upload a logo for the main page index.php but it says " The current role does not have access to this operation" yet I am the admin for this program. Please help.


#37

I’ve tried to do the same with the same result, so I cannot upload the logo of the university library. Uploading CSS does not wotk either. The system was upgraded yesterday to 3.1.1.4 from 3.1.0.1 if it matters. The database is up to date and there is an HAProxy between OJS and the client, but I don’t think it could be a problem.

Have you solved it already, jademontemayor?


#39

Same problem here. Fresh install of 3.1.1-4. The admin is not allowed to upload a css file or a logo in the process of setting up a journal.


#40

Hi all,

That has already been corrected using this patch (apply in lib/pkp): https://github.com/pkp/pkp-lib/commit/fee172dd11ac88777ed7f73330303759079d5f9c

Regards,
Alec Smecher
Public Knowledge Project Team


#41

Tenemos instalado OJS 3.1.1.4

Tengo problemas con ciertos Revisores. Por ejemplo tengo un revisor que ha pasado por todas las etapas de revisión y ya está en la etapa (4) de Finalización.

En Review Discussions, se agregó una nueva discusión en la cual junto al mensaje se adjuntó un archivo PDF para que sea descargado por el revisor.

El revisor al hacer clic sobre el archivo adjunto obtiene una página en blanco con esto:

{“status”:false,“content”:“The current role does not have access to this operation.”,“elementId”:“0”,“events”:null}

:frowning:

We have OJS 3.1.1.4 installed

I have problems with certain reviewers. For example I have a reviewer who has gone through all the review stages and is already in stage (4) of Completion.

In Review Discussions, a new discussion was added in which a PDF file was attached to the message to be downloaded by the reviewer.

The reviewer when clicking on the attachment gets a blank page with this:

{“status”:false,“content”:“The current role does not have access to this operation.”,“elementId”:“0”,“events”:null}