OJS 3 Submission metadata saving issues

Hi
We have moved to the latest version of OJS, and we are changing some aspects of metadata of the articles (references and abstract). Changes in references take place in portal view, spite the fact that it does not end the saving process (continuous loading). The changes in abstract do not take place.
We appreciate some inputs.
Many thanks, Helena

1 Like

Hello. Same problem Here.

When you edit “metadata” from an article.
Then, you save it.
Saved, but always loading.
Then, You can’t to save another time.
You have to close and to open another time.

Video
https://upload.disroot.org/r/IJM5clVN#ck+IH3u43JlB0+HRnRemHYM4DnJhUjz5s0aX4EhZcqk=

Hi all,

See Submission metadata form: pressing save button triggers browser errors · Issue #4072 · pkp/pkp-lib · GitHub.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

We applied the suggested change of the forum (Comparing 174bf109a2bcca73df0b4658d014afbc078696fd...65475ba862e1ed5cad8f03ea34680be86a3dbe7e · pkp/pkp-lib · GitHub), but it did not have any effect, and the error remains the same.
The error that is returned is slightly different from that presented in the forum (attached image).image001 image001
We are about to publish an issue, and we much appreciate your help.
Thanks

Hi @rpics_editor,

Are you using minified Javascript (see config.inc.php)? See the note at Submission metadata form: pressing save button triggers browser errors · Issue #4072 · pkp/pkp-lib · GitHub.

Regards,
Alec Smecher
Public Knowledge Project Team

Hello,
I have similar issue. When I click ‘save and continue’ in submission metadata page, the wheel continues to roll but nothing happens. i don’t even get the ‘saved’ message as in the case of others.
I have done all at Submission metadata form: pressing save button triggers browser errors · Issue #4072 · pkp/pkp-lib · GitHub but nothing changed. Please help.

Thanks

Hi @frankfreds,

Can you confirm which patches you applied?

Regards,
Alec Smecher
Public Knowledge Project Team

Thanks @asmecher ,
I’ve applied asmecher@65475ba .
I also enabled minified JS and applied pkp/ojs@322f3ae

Hi @frankfreds,

Have you hard-flushed your browser cache?

Regards,
Alec Smecher
Public Knowledge Project Team

I have cleared the browser cache the normal way through its options/settings.
Please how do I do the hard-flushing?

Thanks

Hi @frankfreds,

See e.g.: Help:Hard Refresh - Scratch Wiki

Regards,
Alec Smecher
Public Knowledge Project Team

Hello, thanks so much for the help so far.
Now the submission works but only when i use a VPN. Without VPN, after login I get a message like ‘you don’t have permission to access this role’ and then it returns me to the login page. Please how do I go about fixing that?