OJS 3: DOI link does not appear in the article

Dear all,

I just got DOI prefix number from crossref. I have enabled and put it in the DOI plugin. I select default option for DOI suffix. After I save, the DOI link doesn’t appear in the article. Are there steps that I have missed?

Thank you

Have you assigned a DOI to an article? Open a article workflow, click “Metadata” and open the “Identifiers” tab.

Also note that seeing the DOI in the article is just step 1. After assigning a DOI, it also needs to be registered by using the CrossRef plugin in the import/export tools.

With the “pattern” options for the DOI suffix, the DOI will be automatically allocated the first time the article is access as a “published” article. The Edit Metadata screen will only display the patterned DOI. If the “Enter an individual DOI suffix for each published item” is chosen, you will have an additional field in the Edit Metadata screen to enter a DOI. As @ajnyga mentions, the DOI will not be registered until submitted to an external agency such as CrossRef or EZID by one of the import/export plugins.

Hi @ajnyga and @ctgraham ,
I just tried assigning the DOI to one article, and finally, DOI link appear. Actually, my journal is backdated issues and has many papers published.
What I understand here, I need manually assign one by one to all articles, am I right?

See this discussion: OJS 3: No DOIs generated

@bozana knows what the situation is with the feature mentioned there.


For now we only implemented a button, that when clicked would assign the DOIs to all published articles i.e. objects selected in the plugin settings. This function is available in the GitHub master branch and would be released latest with 3.1 release.
I am not sure if the changes would work for the 3.0.2 release, but maybe you could try it? You would need to apply these commits:
in lib/pkp:
in ojs:
and eventually also pkp/pkp-lib#2342 improve text content and display, remove a notificat… · pkp/ojs@876d149 · GitHub


1 Like