OJS 3: adding reviewer doesn't send email as expected

Hello!

My OJS is missing some emails on the “adding reviewer” process. If I send a “Unassign reviewer” my OJS sends the email without any problem… I’ve checked with my tech team the logs of the server and the email system but didn’t see anything weird… in fact, we think that the OJS is not sending those emails and that’s why they never show up in the logs of the email system.

Hope you guys can help us.

Hi @Juan_Lopez,

Can you provide a few more details:

What version of OJS are you using?
Which specific emails to believe are not being sent?

-Roger
PKP Team

Hi @rcgillis

I’m using OJS 3.2.1.1 and the emails that are not being sent belongs to this function:
image

Thanks for your response.

image
I think this is the email that’s being sent irregularly

Hi @Juan_Lopez,

Thank you for providing these additional details.

If there is no trace of the review request email in the logs, could you please check the following and let us know what the results are?

  1. Have any invitation emails been found in the receivers’ Spam folders?
  2. Is the Article Review Request email template enabled in Settings > Workflow > Email?
  3. Has the Article Review Request email template been changed from the default?
  4. Is the bounce email set in your email configuration? If so, has it received any messages about these mails failing to be delivered?
  5. Is there any trace of the invitation mail being sent in the Activity Log of the affected submissions?

-Roger
PKP Team

Sure thing,

  1. There is no email in the spam folder, and also, there is no email sent to the reviewer from my ojs email “Sent” folder.
  2. Yes, it is enabled.
  3. The email template has not been changed from the default.
  4. When the email is not sent, there’s no track of said email in my inbox… is like OJS never started the request to sent the email.
  5. When the email is not sent, you can see this in the Activity log:
    image
    and when is sent, you can see this:
    image

Thanks for the reply!