OJS 3.4.0.4 - ROR plugin not in plugin gallery

Describe the issue or problem

I tried to activate the Research Organisation Registry (ROR) plugin, following the steps described on https://docs.pkp.sfu.ca/ror-plugin/en/ror-plugin. However, the ROR plugin does not show up.

Steps I took leading up to the issue

I went to the plugin gallery, searched for plugin, and did not find it.

I also tried to download the plugin from https://github.com/withanage/ror and install it manually. But that version of the plugin appears not to work with OJS 3.4.0.4.

What application are you using?

OJS 3.4.0.4

Additional information

Here is a screen shot of the plugin gallery of our OJS instance:

Thanks for your help.

1 Like

Hi @odkr,

It looks as though this plugin has not yet been ported to OJS 3.4. @Dulip_Withanage, may be able to speak to whether or not there are plans do this in the future.

Best regards,

Roger
PKP Team

1 Like

@odkr it is not yet updated. I am planning for it. Took a while in the coming 2-3 weeks, I will do that.

3 Likes

@Dulip_Withanage Thank you. We will appreciate if you could let us know when it is updated. Thank you!

@EvelynTl just a update ! @gaziyucel has started on doing the upgrade. We will update as soon as we have a testing version!

1 Like

Hi @EvelynTl / @Dulip_Withanage / @odkr. I can confirm that I am working on it at this very moment. I will ping you here when it’s ready.

4 Likes

Hi all, the development is done.
The changes are waiting for review, merge and release.
You can have a peak here. GitHub - GaziYucel/ror at stable-3_4_0.

Please wait for the release before using in production!

Hi @gaziyucel It’s working fine with OJS-3.4. Can we use it on production or wait?

Hi @shantanusingh ,
thanks fo testing , I will update the plugin version in plugin gallery next week!

may be use the plugin from plugin gallery then, which will be maintained long-term.

Hi @shantanusingh @EvelynTl @odkr ,

OJS 3.4 ROR plugin is in plugin gallery now!

4 Likes

Thanks a lot!

However, when we try to install the plugin, we get the error message “Plugin already installed, and is newer than the version available in the gallery.”

We had tried to use the version on GitHub previously, but we did delete that version before trying to install the new one:

% find plugins -name '*ror*'
plugins/reports/counter/templates/soaperror.tpl
MariaDB [ojs]> select unique plugin_name from plugin_settings where plugin_name like '%ror%';
Empty set (0.002 sec)

I would be grateful for some pointers what else I could do to try fix this.

Hi @odkr,

there are two places where information about plugins are saved:

  1. select * from plugin_settings where plugin_name like ‘%ror%’;
  2. select * from versions where product like ‘%ror%’;

I suspect that there is still an entry in the versions table.

Can you post what you have there?

Thanks.

Yes, that was the issue. I deleted the entries from the versions table and could now install the new version of the ROR plugin. Thanks a lot!